polilaibe
01.02.2022 11:14

Написать программу: Описать функцию вычисления f(x) по формуле: f(x)= 1)x^2 при -2<=x<2;

2)x^2+4x+5 при x>=2;

3)4 при x<-2.

Используя эту функцию для n заданных чисел, вычислить f(x). Среди вычисленных значений найти наибольшее.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
222812
03.01.2020 17:11
//Боль
//Pascal ABC.NET 3.1 сборка 1219

Var
 f:text;
 max,min,p:real;
 maxn,minn,n,i:integer;
 ar:array of real;
 s:string;
begin
max:=real.MinValue;
min:=real.MaxValue;
n:=0;
 assign(f,'text.txt');
 reset(f);
 while not(Eof(f)) do
  begin
   read(f,p);
   inc(n);
   setlength(ar,n);
   ar[n-1]:=p;
   if ar[n-1]>max then
    begin
     max:=ar[n-1];
     maxn:=n-1;
    end;
   if ar[n-1]<min then
    begin
     min:=ar[n-1];
     minn:=n-1;
    end;
  end;
 close(f);
swap(ar[minn],ar[maxn]);
for i:=0 to n-1 do
if i<>n-1 then s:=s+floattostr(ar[i])+' '
else
s:=s+floattostr(ar[i]);
rewrite(f);
write(f,s);
close(f);
end.

Пример содержимого text.txt:
0 -2.1 1.1
Пример содержимого text.txt после работы программы:
0 1.1 -2.1
0,0(0 оценок)
Ответ:
данил1771
30.07.2020 15:51
#include <iostream>
using namespace std;
double val, p;
//вводимые параметры значения функции и степень полинома
//x - значение функции
//res - значение, которое изменяется в процессе рекурсии по схеме Горнера
//s - рассматриваемая текущая степень x
double rec(double x, double res, double s) 
{
  if (s == 0.0)
    return res;
  return rec(x, x * res + s - 1, s - 1);
}
int main(){
  cin >> val >> p;
  //старший коэффициент в схеме Горнера сначала сносится вниз, 
  //поэтому его передаем в качестве начального параметра для результата
  cout << fixed << rec(val, p, p) << endl;
  return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота