kristinkadulesova
07.10.2020 15:11

Написать программу: Описать функцию вычисления f(x) по формуле:
1) f(x)= x^2 при -2<=x<2;

2)x^2+4x+5 при x>=2;

3)4 при x<-2.

Используя эту функцию для n заданных чисел, вычислить f(x). Среди вычисленных значений найти наибольшее.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vikylev011
16.03.2020 06:27

Если остались какие-то вопросы пиши

Объяснение:

ответ:Линейные алгоритмы – алгоритмы, в которых используется алгоритмическая конструкция «Следование», отображающая естественный, последовательный порядок действий. Алгоритм как собраться в школу :

1. Поставить будильник на 7 00 утра

2. Проснуться в 7 00

3. Выключить будильник

4. Пойти умываться

5. Позавтракать

6. Собрать учебники , тетради, пенал

7. Одеться

8. Взять вторую обувь

9. Выйти из дома.

Для изображения алгоритма графически используют блок-схемы

0,0(0 оценок)
Ответ:
Anna200689898098654
08.07.2020 08:02

Значение дроби можно вычислять так: начинаем с e = 0, затем обновляем значение e по формуле n / (n + e), уменьшая n, пока не получим 2 / (2 + ...). В конце прибавим к результату 2. Пример:

0\to \dfrac4{4+0}\to \dfrac3{3+\dfrac4{4+0}}\to\dfrac2{2+\dfrac3{3+\dfrac4{4+0}}}\to2+\dfrac2{2+\dfrac3{3+\dfrac4{4+0}}}

Все скучные операции с дробями оставим питону, пусть считает сам - у него для этого есть модуль fractions.

Знаменатели растут очень быстро - уже начиная с числа 13 знаменатель будет больше миллиарда.

Код (Python 3):

from fractions import Fraction

from itertools import count

n = int(input())

for k in count(3):

   e = Fraction(0)

   while k >= 2:

       e = k / (k + e)

       k -= 1

   e += 2

   a, b = e.numerator, e.denominator

   if b > n:

       print(a, b)

       break

Пример ввода:

1000000000

Пример вывода:

6706022400 2467007773

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота