ZnatokisRussia
21.05.2023 12:53

Составьте программу, в которой

используется 2 вида процедур, которые в

качестве входных данных получают три

целых числа и вычисляет их сумму,

произведение и среднее арифметическое

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pula04
03.09.2020 08:04

Задание 2.

program prog;

function F(n:integer):integer;

begin

   if n<=1 then F:=1

   else F:=F(n-1)+F(n-2)

end;

begin

   write(F(7))

end.

Вывод программы: 21

Задание 3.

program prog;

function F(n:integer):integer;

begin

   if n<=1 then F:=1

   else F:=F(n-1)*F(n-2)+2

end;

begin

   write(F(5))

end.

Вывод программы: 87

Задание 5.

program prog;

procedure F(n:integer);

begin

   write('*');

   if n > 0 then begin

       F(n-2);

       F(n-2);

       F(n div 2);

   end

end;

begin

   F(5);

end.

Вывод программы (34 звёздочки):

Задание 6.

program prog;

procedure F(n: integer);

begin

   write('*');

   if n > 0 then begin

       F(n-3);

       F(n-2);

       F(n div 2);

       F(n div 2);

   end

end;

begin

   F(6);

end.

Вывод программы (97 звёздочек):

Задание 7.

program prog;

procedure F(n: integer);

begin

   write('*');

   if n > 0 then begin

       write('*');

       F(n-2);

       F(n-2);

       F(n div 2);

   end

end;

begin

   F(6);

end.

Вывод программы (77 звёздочек):

0,0(0 оценок)
Ответ:
Hiipotatohihi
19.01.2022 14:15

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested inTraveller

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested inTraveller

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested inTraveller

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested inTraveller

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested inTraveller

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested inTraveller

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested inTraveller

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested inTraveller

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested inTraveller

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested inTraveller

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested inTraveller

e verbs in

lian restaurant. He couldn't

(3)

(work

iness, his own restaurant. At

Adam wasn't interested in

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота