AngelInna228322
23.07.2022 22:58

Составьте программу в Pascal abc, которая с клавиатуры позволяет ввести количество информации в мегабайтах, килобайтах, байтах и битах. В результате нужно получить количество информации в битах.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
elenafrolova31
13.10.2020 21:22

var mb,kb,byte,bit, result : Real;

begin

write('Mb. = '); readln(mb);

write('Kb. = '); readln(kb);

write('Byte = '); readln(byte);

write('Bit = '); readln(bit);

result := mb * 1014 * 1024 * 8;

result := result + (kb * 1024 * 8);

result := result + (byte * 8);

result := result + bit;

writeln(result:0:2);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота