KY3bMA228
01.02.2022 00:11

Составьте программу на Паскале
На вход программы поступает неизвестное количество натуральных чисел, ввод заканчивается нулём. Найти минимальное из введённых нечётных чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
diyarbek2120313
13.10.2020 21:21

var a, min:integer;

begin

writeln('Введите числа (цифра 0 - выход из программы)');

readln(a);

min:= a;

while(a <> 0) do begin

 if (((a mod 2) = 1) and (min > a)) then

   min:= a;

readln(a);

end;

writeln('Минимальное нечетное число: ', min);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота