Biszkopt99
23.04.2020 14:09

Меня зовут Иван. Составьте программу, которая печатает в первой строке одну первую букву Вашего имени, во второй – две первые буквы, в третьей -3, ..., в строке с номером к - к первых букв.

Печать строки оформить через процедуру. Число строк вводить с клавиатуры.

Текст Вашей программы сохранить в файл PascalABC.net. Прикрепить файл программы к этому заданию.

После begin основной программы написать что делает эта программа writeln('Программа печает(выводит на экран)...(заполнить) ');

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Giga45
28.09.2022 13:28
1. 16 бит * 512 = 2 байт * 512 = 1024 байт = 1 Кбайт (4)
2. 480 бит / (2 байта) = 480 бит / 16 бит = 30 (4)
3. 2 Кбайта / 2048 = 2048 байт / 2048 = 1 байт = 8 бит (3)
4. 29 символов * 1 байт/символ = 29 байт = 232 бит (3)
5. 16 * 35 * 64 * 8 бит = 16 * 35 * 64 байт = 35 * 1024 байт = 35 Кбайт (1)
6. 6 Кбайт / (64 * 16 * 2 байт) = 6 Кбайт / (2 * 1024 байт) = 6 Кбайт / 2 Кбайт = 3 (2)
7. 18 Кбайт / (12 * 16 * 2 байт) = 18 * 1024 / (12 * 16 * 2) = 48 (3)
8. 25 Кбайт / (8 * 25 * 8 бит) = 25 * 1024 / (25 * 8) = 128 (1)
9. 256 * 16 бит = 256 * 2 байт = 512 байт (4)
10. 160 бит / 1 байт = 160 / 8 = 20 (3)
11. (1,5 Кбайт) / 3072 = (1,5 * 1024 байт) / (3 * 1024) = 0,5 байт = 4 бит (2)
12. 39 символов * 16 бит/символ = 39 * 16 бит = 39 * 2 байт = 78 байт (2)
13. 8 * 40 * 64 * 16 бит = 40 * 64 * 16 байт = 40 * 1024 байт = 40 Кбайт (1)
14. 80 Кбайт / (128 * 64 * 2 байт) = 80 Кбайт / (128 * 8 * 16 байт) = 80 Кбайт / (16 * 1024 байт) = 80 / 16 = 5 (3)
15. 30 Кбайт / (15 * 32 * 1 байт) = 30 * 1024 / (15 * 32) = 2 * 32 = 64 (4)
16. 75 Кбайт / (16 * 50 * 8 бит) = 75 Кбайт / (16 * 50 байт) = 75 * 1024 / (16 * 50) = 75 * 1024 / (25 * 32) = 3 * 32 = 96 (2)
17. 4 = 2^2, на 1 символ 2 бита. 2 бита * 40 = 80 бит = 10 байт (1)
18. 12 байт / 48 символов = (12 * 8 бит) / (12 * 4) = 2 бита, поэтому 2^2 = 4 (4)
19. 32 = 2^5, поэтому 5 бит на 1 символ. 25 байт / 5 бит = 25 * 8 / 5 = 40 (1)
20. 128 = 2^7, 7 бит на символ. 7 бит * 32 = 7 * 4 байт = 28 байт (3)
21. (9 байт) / 24 = 72 бит / 24 = 3 бит; 2^3 = 8 (2)
22. 8 = 2^3, 3 бита на символ. 45 байт / 3 бит = 15 байт / бит = 15 * 8 = 120 (3)
0,0(0 оценок)
Ответ:
pogoreiko
29.08.2021 23:43
ответ: 4Объяснение:

Создаём массив из 11 элементов, который называем Dat:

целтаб Dat[1:11]

Объявляем переменные к и ш, являющимися целыми числами:

цел к, ш

Заполняем массив Dat:

Dat[1]:=21 Dat[4]:=19 Dat[7]:=23 Dat[10]:=29 Dat[2]:=23 Dat[5]:=25 Dat[8]:=21 Dat[11]:=19 Dat[3]:=20 Dat[6]:=22 Dat[9]:=22

Присваиваем переменной ш значение 0.

ш:=0

Объявляем цикл от 1 до 11, то бишь пробегаемся по массиву Dat и смотрим, если значение элемента больше 22, то прибавляем к переменной ш 1:

нц для к от 1 до 11 если Dat[к]>22  то    ш:=ш+1 Все кц

Выводим на экран значение переменной ш:

вывод ш

Таким образом мы видим, что программа подсчитывает количество классов в которых больше 22 учеников. Таких классов будет 4: 2(23), 5(25), 7(23) и 10(29).

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота