gulkogulkovno
16.12.2021 17:34

CРОЧНО
Написать программу вычисления среднего арифметического величин x1, x2 и x3. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).

Вычисление среднего арифметического.

Введите исходные данные:

Величина x1 -> 6.9

Величина x2 -> 2.1

Величина x3 -> 3

Среднее арифметическое: 4.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Legodgidai
23.04.2023 15:56

PROGRAM ThreeNumbers;

VAR

   numberOne : DOUBLE;

   numberTwo : DOUBLE;

   numberThree : DOUBLE;

   sum : DOUBLE;

   product : DOUBLE;

   average : DOUBLE;

BEGIN

   WriteLn('Введите три числа:');

   Write('Число 1 -->');

   ReadLn(numberOne);

   Write('Число 2 -->');

   ReadLn(numberTwo);

   Write('Число 3 -->');

   ReadLn(numberThree);

   sum := numberOne + numberTwo + numberThree;

   product := numberOne * numberTwo * numberThree;

   average := (numberOne + numberTwo + numberThree) / 3.0;

   WriteLn('Сумма = ', sum:6:1);

   WriteLn('Произведение = ', product:6:1);

   WriteLn('Среднее = ', average:6:1);

END.

0,0(0 оценок)
Ответ:
пипл4
23.04.2023 15:56
#include <iostream>
using namespace std;

int main() {
int a, b, c;
cout << "Введите 3 целых числа:\n";
cin >> a >> b >> c;
    cout << a << "+" << b << "+" << c << "=" << a+b+c << "\n";
cout << a << "*" << b << "*" << c << "=" << a*b*c << "\n";
cout <<"("<<a<<"+"<<b<<"+"<<c<<")/3="<<(a+b+c)/3.0<<"\n";
return 0;
}

Пример:
Введите 3 целых числа:
5 7 8
5+7+8=20
5*7*8=280
(5+7+8)/3=6.66667
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота