Alexa2608
12.08.2022 10:55

(Pascal) Сформировать массив В из произведений элементов столбцов мас-сива Z:

Z(m,n)= 5 8 3.1 6 -1
4.2 15 2 3 0.9 m=2 n=5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MaTeMaTiKjjj
14.05.2022 11:17
Задание №1 

var s,v,t,a:real; 
begin 
writeln('Введите скорость, ускорение и время соотвественно'); 
read(v,a,t); 
s:=v*t+(a*sqr(t))/2; 
writeln('Расстояние S = ',s); 
end.

Задание №2

var a,b,c,d,m,n:integer; 
begin 
writeln('Введите ширину и высоту комнаты'); 
read(a,b); 
writeln('Введите размеры окна'); 
read(c,d); 
writeln('Введите размеры двери'); 
read(m,n); 
writeln('Площадь стен для оклеивания обоями = ',a*b-c*d-m*n); 
end.

Задание №3

var a,b:real; 
begin 
writeln('Введите два числа'); 
read(a,b); 
writeln('Среднее арифметическое кубов этих чисел = ',(power(a,3)+power(b,3))/2); 
writeln('Среднее геометрическое модулей этих чисел = ',sqrt(abs(a*b))); 
end.

Задание №4

var x:real; 
begin 
writeln('Введите ребро куба'); 
read(x); 
writeln('Площадь грани = ',sqr(x)); 
writeln('Площадь полной поверхности = ',6*sqr(x)); 
writeln('Объем куба = ',power(x,3)); 
end.

Задание №5

var r1,r2:real; 
begin 
writeln('Введите внешний и внутренний радиус'); 
read(r1,r2); 
if r1<r2 then writeln('Внешний радиус должен быть больше внутреннего') else 
writeln('Площадь кольца = ', Pi*sqr(r1)-Pi*sqr(r2)); 
end.
0,0(0 оценок)
Ответ:
polinaleskevic
07.10.2020 03:30
Pascal ABC.Net 3.3.5

Вот только программа выдает, что таких чисел нет )))

program Poisk;

var
  i, a, b, c, d: integer;

begin
  for i := 100 to 999 do
    a := sqr(i); {переменной а присваиваем квадрат числа}
  b := a mod 10; {переменной b присваиваем остаток основного числа. Это 1-я цифра}
  a := a div 10; {переменной а присваиваем целую часть основного числа}
  c := a mod 10; {переменной c присваиваем остаток числа. Это 2-я цифра}
  a := a div 10; {переменной а присваиваем целую часть числа}
  d := a mod 10; {переменной d присваиваем остаток числа. 3-я цифра}
  a := b + c + d; {переменной а присваиваем сумму 3-х цифр}
 
  if a = i {если а = основному числу}
    then writeln(i, ' ', a) {то вывод такого числа}
  else writeln('Таких чисел нет.'); {иначе вывод, что таких чисел нет}
end.

Напишите программу поиска трехзначных чисел, таких, что сумма трех цифр на которые оканчивается квад
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота