bolshakovatanyoxd2gr
26.05.2021 05:25

Сережа и Петя измеряют свой рост в сантиметрах. Составьте программу и блок-схему,
алгоритм которых определяет, кто выше. ответ должен быть представлен в виде: «Выше
Сережа» или «Выше Петя». (Известно, что мальчики не одинакового роста)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
торежан1
03.04.2023 15:12
Program pr3;
Var A : array [1..100, 1..100] of integer ; {резервирование памяти под массивы}
B : array [1..100, 1..100] of integer ;
C : array [1..100, 1..100] of integer ;
m, n, i,j: integer ; {переменные i,j вводятся как индексы массива}
Begin
randomize;
writeln ('Введите размерность матриц m и n (числа <100)');
readln (m, n);
For i:=1 to m do
For j:=1 to n do
begin
A[i,j]:=random (20)-10; {ввод элемента матрицы}
B[i,j]:=random (20)-10; {ввод элемента матрицы}
end;
writeln ('Итоговая матрица A: ');
For i:=1 to m do
begin
For j:=1 to n do write (A[i,j], ' '); {вывод элементов производится в виде матрицы }
writeln; {после перебора всех столбцов одной строки – переход новую строку}
end;
writeln;
writeln ('Итоговая матрица B: ');
For i:=1 to m do
begin
For j:=1 to n do write (B[i,j], ' '); {вывод элементов производится в виде матрицы }
writeln; {после перебора всех столбцов одной строки – переход новую строку}
end;
writeln;
For i:=1 to m do {цикл по всем строкам матрицы}
For j:=1 to n do {цикл по всем столбцам матрицы}
if (A[i,j] < B[i,j]) then C[i,j] := B[i,j] else C[i,j] := A[i,j];
writeln ('Итоговая матрица C: ');
For i:=1 to m do
begin
For j:=1 to n do write (C[i,j], ' '); {вывод элементов производится в виде матрицы } writeln; {после перебора всех столбцов одной строки – переход новую строку}
end;
end.
0,0(0 оценок)
Ответ:
kustsireni
31.03.2023 05:59
Program zic;
var a,b,c,d,e:integer;
begin
Writeln('Введите 5 чисел');
Readln(a,b,c,d,e);
if (a>0) and (b>0) and (c>0) and (d>0) and (e>0) then Write('',Ваши числа положительные) else
if a>0 and b>0 and c>0 and d>0 and e<0 then Write('',Все ваши числа положительные кроме числа e) else
if a>0 and b>0 and c>0 and d<0 and e>0 then Write('',Все ваши числа положительные кроме числа d) else
if a>0 and b>0 and c<0 and d>0 and e>0 then Write('',Все ваши числа положительные кроме числа c) else
if a>0 and b<0 and c>0 and d>0 and e>0 then Write('',Все ваши числа положительные кроме числа b) else
if a<0 and b>0 and c>0 and d>0 and e>0 then Write('',Все ваши числа положительные кроме числа a) else
if a>0 and b>0 and c>0 and d<0 and e<0 then Write('',Все ваши числа положительные кроме числа d и e) else
if a>0 and b>0 and c<0 and d>0 and e<0 then Write('',Все ваши числа положительные кроме числа c и e) else
Дальше просто меняеш знаки и числа.
Концовка такая
if a<0 and b<0 and c<0 and d<0 and e<0 then Write('',Все ваши числа
 отрицатильные);
end.
P.s. Все эти с<0 и т.д. поставь в скобки
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота