СлишкомУмная1
08.06.2020 18:29

Напишите программу на C++ не сложную с объяснением.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Абдусатор
25.04.2020 13:30
калькулятор сам составлял

#include<iostream>

 

using namespace std;

 

int main()

{

   setlocale( LC_ALL, "Russian" );

       float a,b,s;

       int dp;

       

   cout << "Привет! Я калькулятор!Какие действие вы будете выполнять:" << endl;

       cout << "1. Сложение. " << endl;

       cout << "2. Отнимание." << endl;

       cout << "3. Умножение." << endl;  

       cout << "4. Деление." << endl;

 

       cout << "Введите число для выбора действия" << endl;

 

       cin >> dp;

 

       switch(dp)

       {

       case 1:

               cout << "Число a = " << endl;

       cin >> a;

       cout << "Число b = " << endl;

       cin >> b;

               s = a + b;

               cout << "\n" << a << " * " << b << " = "<< s << endl;

   break;

 

case 2:

               cout << "Число a = " << endl;

       cin >> a;

       cout << "Число b = " << endl;

       cin >> b;

               s = a - b;

               cout << "\n" << a << " * " << b << " = "<< s << endl;

               break;

 

 

case 3:

               cout << "Число a = " << endl;

       cin >> a;

       cout << "Число b = " << endl;

       cin >> b;

               s = a * b;

               cout << "\n" << a << " * " << b << " = "<< s << endl;

               break;

 

               case 4:

               cout << "Число a =  "  << endl;  

               cin >> a;

               cout << "Число b =  " << endl;

       cin >> b;

               s = a / b;

               cout << "\n" << a << " / " << b << " = "<< s << endl;

               break;

       }

       

 

return 0;

}

1

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота