Составить программу, которая печатает True, если точка с коор динатами (x, y) принадлежит заданным закрашенным (заштрихо- ванным) областям, показанным на рисунках в табл. 1, и False — в противном случае.
var i,z,y,x: integer; // объявление переменных begin // начало программы writeln('Введите числа: '); // Вывод сообщения readln(x,y); // Ввод чисел х и у с клавиатуры while i <> y do // Повторять цикл пока i не будет равно y begin // Вход в цикл z:=z+x; // z = z + x (при первом шаге получается 0 = 0 + х) i:=i+1; // Увеличиваем счетчик цикла на 1 end; // Выход из цикла write(z); // Вывод z (произведение х и у) end. // Конец программы
var i,z,y,x: integer; // объявление переменных begin // начало программы writeln('Введите числа: '); // Вывод сообщения readln(x,y); // Ввод чисел х и у с клавиатуры while i <> y do // Повторять цикл пока i не будет равно y begin // Вход в цикл z:=z+x; // z = z + x (при первом шаге получается 0 = 0 + х) i:=i+1; // Увеличиваем счетчик цикла на 1 end; // Выход из цикла write(z); // Вывод z (произведение х и у) end. // Конец программы
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку