iznaur2002
17.04.2022 12:32

Написать программу для вычисления функции f=x4+x3-x2-10. ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
calusiker
12.01.2021 15:31
Const
  n = 5;{ это позволяет в одном месте изменить количество чисел }

type
  numeric = real;{ это позволяет в одном месте изменить тип чисел }

var
  max, min: numeric;
  i: integer;
  a: array[1..n] of numeric;

begin
  Writeln('Введите ', n, ' произвольных чисел через пробел');
  Read(a[1]);
  min := a[1]; max := min;
  for i := 2 to n do
  begin
    Read(a[i]);
    if max < a[i] then max := a[i]
    else
    if min > a[i] then min := a[i]
  end;
  Writeln('Минимальное введенное: ', min, ', максимальное: ', max)
end.

Тестовое решение:
Введите 5 произвольных чисел через пробел
34 157 -84.54 14.843 -13.64
Минимальное введенное: -84.54, максимальное: 157
0,0(0 оценок)
Ответ:
Ozabo4eniy
12.01.2021 15:31
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 #include <iostream> #include <windows.h> using namespace std; void main() {     SetConsoleOutputCP(1251);     int num, col;     int a=0;     int min;     cout << "Программа которая находит минимальное из введенных пользователем чисел." << endl;     cout << "Сколько чисел вы введёте ?" << endl;     cin>>col; cin>>num; min=num;     do {     cout << "Введите число --> ";     cin >> num;     if (min>num) {     min=num;     }     a++;     } while (a < col-1); cout<<min<<endl; }
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота