hjccbyfoyf6ui
17.02.2020 16:02

работу нужно сделать в Pascal

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kfhjrhnf
13.02.2023 13:05

using System;


class Program

{

private static int GetThird(int num)

{

var result = 0;

var kv = num * num;

if (num % 2 == 0)

{

for (var i = num / 2; i > 0; i--)

{

result += kv - i * 2 + 1;

}

for (var i = 0; i < num / 2; i++)

{

result += kv + i * 2 + 1;

}

}

else

{

for (var i = (num - 1) / 2; i > 0; i--)

{

result += kv - i * 2;

}

result += kv;

for (var i = 0; i < (num - 1) / 2; i++)

{

result += kv + i * 2 + 2;

}

}

return result;

}


//оптимизированное свое решение, коротко и ясно

private static int GetThirdOptimized(int num)

{

var result = 0;

var kv = num * num - num + 1;


for (var i = 0; i < num; i++)

{

result += kv + i * 2;

}


return result;

}


private static void Main()

{

Console.WriteLine("Введите натуральноe числo ");

var i = int.Parse(Console.ReadLine());

Console.WriteLine("{0}^3 = {1} = {2} = {3}", i, i * i * i, GetThird(i), GetThirdOptimized(i));

Console.Read();

}

}

0,0(0 оценок)
Ответ:
Andezia
06.02.2021 02:50
Procedure TForm1.Button1Click(Sender: TObject);
var
  i1,i2,i3 : Integer;
  kk : Integer;
  Chislo : Integer;
begin
  Memo1.Clear;
  kk := 0;
  for i1 := 1 to 9 do
    for i2 := 0 to 9 do
      for i3 := 0 to 9 do
        if ( (i1<>i2) and (i1<>i3) and (i2<>i3) ) then
          if ( Frac((i1+i2+i3)/7)=0 ) then
          begin
            Chislo := i1*100 + i2*10 + i3;
            if ( Frac(Chislo/7)=0 ) then
            begin
               Memo1.Lines.Append(inttostr(Chislo));
               inc(kk);
            end;
          end;
end;


Написать программу на языке паскаль нахождения всех трехзначных чисел, у которых все цифры различны,
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота