АняЕнот
27.06.2020 11:51

Составить программу на языке Python по условию: Даны a,b,c - стороны предлагаемого треугольника. Требуется сравнить длину каждой стороны с суммой двух других. Если хотя бы в одном случае длина окажется больше суммы двух других, то выходит сообщение "такого треугольника не существует", иначе выходит сообщение "Истина"​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Renton8546
06.10.2022 03:06
Const
  n = 15;

var
  a: array[1..n] of integer;
  i: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  for i := 1 to n do
  begin
    a[i] := Random(61) - 30;
    Write(a[i]:4);
    if a[i]>0 then a[i]:=2*a[i]
    else
      if a[i]<0 then a[i]:=7
  end;
  Writeln;
  Writeln('После преобразования');
  for i := 1 to n do Write(a[i]:4);
  Writeln
end.

Тестовое решение:
Элементы массива
 -20  15  16  20   0  16 -15  -1  -2  21  -8 -10   4 -24   1
После преобразования
   7  30  32  40   0  32   7   7   7  42   7   7   8   7   2
0,0(0 оценок)
Ответ:
igubanova
06.10.2022 03:06
Const
  n = 15;

var
  a: array[1..n] of integer;
  i: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  for i := 1 to n do
  begin
    a[i] := Random(61) - 30;
    Write(a[i]:4);
    if a[i]>0 then a[i]:=2*a[i]
    else
      if a[i]<0 then a[i]:=7
  end;
  Writeln;
  Writeln('После преобразования');
  for i := 1 to n do Write(a[i]:4);
  Writeln
end.

Тестовое решение:
Элементы массива
 -20  15  16  20   0  16 -15  -1  -2  21  -8 -10   4 -24   1
После преобразования
   7  30  32  40   0  32   7   7   7  42   7   7   8   7   2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота