Каролина9999
06.08.2022 21:54

Составить программу для вычисления пути, пройденного лодкой, если ее скорость в стоячей воде V1 км/ч, скорость течения реки V2 км/ч, время движения по озеру T1 ч, а против течения реки - T2 ч.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
блашер
28.08.2022 00:41
Могу в предложить в данном случае использовать goto и метки. Ну, если вы имеете какой то признак неправильных данных, например, это отрицательные значения (предположим, что это неправильные данные) То на этапе, когда вы вводите эти значения, вы должны поставить условный оператор. Т.е.
if a<0 tnen
begin
Writeln('Вы ввели неверные данные');
goto 1
else
goto 2;
Метку 1 вы ставите в начало алгоритма, т.е. туда, откуда вы хотите начать повторное выполнение программы, а метку 2 поставить в продолжение алгоритма, т.е. на тот случай, если данные были введены верно
0,0(0 оценок)
Ответ:
sennik41
23.05.2023 14:48
Uses graphABC;beginsetwindowsize(600,500);setbrushcolor(clMedGray);Ellipse(320,30,490,400);Ellipse(120,30,300,400);setbrushcolor(clCream);Ellipse(335,40,480,380);Ellipse(140,40,280,380);setbrushcolor(clMedGray);Ellipse(100,430,500,130);setbrushcolor(clNavy);Ellipse(250,240,200,310);Ellipse(350,240,400,310);setbrushcolor(clwhite);Ellipse(240,270,220,300);Ellipse(360,270,380,300);
setbrushcolor(clblack);Ellipse(270,330,330,370);line(300,370,300,400);Arc(300,280,120,220,-40);
line(50,350,200,350);line(30,340,190,340);line(10,330,180,330);
line(410,330,570,330);line(400,340,560,340);line(390,350,550,350);
line(240,230,220,150);line(230,230,180,80);line(220,230,180,150);
line(360,230,380,150);line(370,230,430,80);line(380,230,430,150);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота