ankadudka
28.10.2020 19:44

Дан алгоритм и Составьте программу на языке программирования. Запишите ниже
алгебраический пример
начало
x=5, y=-6
если (x больше y), то z=y-x
иначе z=y-x
вывод z
конец​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tamirisis7sk
29.05.2021 12:26
Меньше в доту катай, все знать будешь :)
1)
uses crt;
var s,s1,s2,s3,r1,r2:real;
begin
writeln ('Введите радиус первого (маленького) круга:');
read (r1);
writeln ('Введите радиус второго (Большего, чем первый) круга:');
read (r2);
//pi - 3.14
s:=3.14*r1*r2 ;
writeln (s);
//s1 - Площадь первого круга, s2 - второго, s3 - кольца
s1:=3.14*sqr(r1);
s2:=3.14*sqr(r2);
if (s1=0) or (s2=0)
then writeln ('Одна из площадей равна нулю')
else begin s3:=s2-s1 ;  
writeln (s3); end
end.

2)
uses crt;
var x,y,x1,y1 :integer;
begin
writeln ('Введите целое значение x:'); // В программе используются только целые числа !!
read (x);
if (x-1)<0 
then y:=4 
else y:=3;
writeln (y);
end.

3)uses crt;
var  a,b,c:real ;
begin
writeln ('Последовательно введите 3 числа :');
read (a,b,c);
if (a<>b) and (b<>c) and (a<>c) 
then writeln ('Числа не равны') 
else
if (a=b) and (b=c) and (a=c) 
then writeln ('Числа все равны между собой')
else
if (a=b) and (b<>c) 
then writeln (c) 
else
if (a=c) and (c<>b) 
then writeln (b) 
else
if (b=c) and (c<>a) 
then writeln (a) 
end.

P.s. Писал на Pascal ABC. Блок-схему сделаешь сам, она не сложная. Удачи, инвакир :D
0,0(0 оценок)
Ответ:
tatyankafi
15.01.2021 15:15

Деректер қорын басқару жүйелері

Өз ойыңызбен бөлісіңіз

Біз үлкен көлемдегі деректерді қалай сақтап, өңдейміз?

Деректер қоры дегеніміз не?

Деректер қорын жасау не үшін қажет?

Деректер қорын жинақтауға арналған қандай программаларды білесіңдер?

Кез келген кәсіпорын немесе ұжым Деректер қорын басқару жүйелерін (ДҚБЖ) жасайды. Олардың көмегімен Деректер қорын жасау­ға, ақпараттармен толықтыруға және жұмыс істеуге болатын программалар жинауға болады. Деректер қорын басқару жүйелерінің бірнеше ондаған түрлері бар, олардың көпшілігі – шындығына келгенде басқару жүйелері емес, арнайы дайындалған программалау тілдері. Осы тілді меңгерген әрбір адам қолданушыға ыңғайлы құрылымдағы, кез келген деректер қорын жасап алуына және оларға қажетті басқару элементтерін енгізуіне болады.

ДҚБЖ (Деректер Қорын Басқару Жүйесі) – деректер қорынан деректерді құру, сақтау және алуды автоматтандыруға арналған программалар жиынтығы.

ДҚБЖ үш негізгі функциясы

1) Деректрді анықтау (деректер қорының сипаттамасы);

​2) Деректерді өңдеу;

​3) Деректерді басқару.

Осы функциялардың барлығын Microsoft Access-те толықтай қолдануға болады.

Тағы да осы тақырып бойынша Басқа іс-әрекеттер

Деректер қорына қойылатын талаптар  

✔ мәліметтер қорының мазмұнын көшіруді болдырмау немесе азайту;

​✔пайдаланушы топтардың құқықтары мен талаптарына сәйкес, деректер қорының жекелеген ақпараттық элементтерге енуін жеделдетуді қамтамасыз ету;

​✔ үнемі өсіп отыратын талаптарды қанағаттандыру үшін деректер қорының кеңейтілу мүмкіншіліктерін қамтамасыз ету;

​✔ тек қана дұрыс, алдын ала тексерілген ақпараттарды пайдалануды қамтамасыз етуге мүмкіндік беретін деректер қорының тұтас­тығын сақтау;

​✔деректер қорының, тұтынушылардың жекелеген санаттарының жұмыс істеуіне қажетті белгілі бір ақпараттық элементтерге енуіне ғана рұқсат беру;

​✔ қорға енуді, деректер қорына ақпараттар қосу мен түзетуді тек қана авторлық құқығы бар тұтынушылардың орындауы;

​✔ деректер қорын пайдаланушылардың талабына сәйкес, деректердің элементтерін, түзету, бейнелеу және есептеу құрылғыларын құрудың қарапайымдылығын қамтамасыз ету.

Есіңізде сақтаңыз

Деректерді сақтау – компьютердің маңызды функцияларының бірі. Оның ең көп тараған құралы – Деректер қоры (ДҚ). ДҚ – берілген құрылымдағы ақпараттардан тұратын арнайы форматтағы файл. Берілгендер кесте түрінде дайындалады.

Деректер қоры (ДҚ) – анықталған облысқа жататын деректерді басқару, сақтау және сипаттаудың жалпы ұстанымдарын анықталған ережелер бойынша қарастыратын ұйымдастырылған деректер жиынтығы.

Тағы да осы тақырып бойынша Басқа іс-әрекеттер

Деректердің арасындағы байланыстарды ұйымдастырудың түрлері

Деректердің арасындағы байланыстарды ұйымдастырудың келесі түрлері бар:

1) Иерархиялық;                                                          ​2) Желілік;                                                     ​3) Реляциялық.

Көптеген ДҚ кестелік құрылымда болады. Кестелік құрылымда берілгендердің адрестері жол мен бағананың қиылысуымен анықталады. Кестелерді жобалау кезінде олардың құрылымдарын алдымен қағазда жасаған ыңғайлы. Кестедегі әрбір өріс оның тақырыбына сәйкес болатын жеке мәліметтен тұрады. Әртүрлі кестедегі берілгендерді байланыстыру үшін, әрбір кестедегі жазбаның өзіндік жеке мәнін бере алатын өріс не өрістер жиынтығы болуы тиіс. Мұндай өріс не өрістер жиынтығын негізгі кілт деп атайды.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота