IgroNUB
05.07.2022 02:01

написать программу на языке Pascal по следующему заданию: Сформировать матрицу А по правилу: , где и - минимальный и максимальный элементы произвольно заданной матрицы B размером 3x4

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
elisavetafolst
13.10.2020 20:03

var A: array [1..4,1..3] of real;

var B: array [1..4,1..3] of integer;

var i,j,max,min: integer;

begin

max:=11;

min:=11;

randomize();

writeln('Произвольная матрица B 3x4:');

For i:= 1 to 4 do

begin

 For j:= 1 to 3 do

 begin

 B[i,j]:=random(100);

 if (B[i,j]<B[min div 10,min mod 10]) then min:=i*10+j;

 if (B[i,j]>B[max div 10,max mod 10]) then max:=i*10+j;

 write(B[i,j]:4);

 end;

 writeln();

end;

writeln('Максимальный элемент матрицы B: ',B[max div 10,max mod 10]);

writeln('Минимальный элемент матрицы B: ',B[min div 10,min mod 10]);

writeln('Матрица A:');

For i:= 1 to 4 do

begin

 For j:= 1 to 3 do

 begin

 A[i,j]:=(2*B[i,j]+B[min div 10,min mod 10])/(B[max div 10,max mod 10]);

 write(A[i,j]:7:3);

 end;

 writeln();

end;

end.


написать программу на языке Pascal по следующему заданию: Сформировать матрицу А по правилу: , где и
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота