titarenko1953
02.09.2021 15:07

Составить программу в visual basic 6.0 и сделать блок схему алгоритма.(Найти номер пожарной части с максимальным количеством автоцистерн )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Gibiskus2
29.07.2020 17:31
VAR
   ans: Real;
   n, i, j, kol: Integer;
   a: Array of Array of Real;
BEGIN
   Read(n); SetLength(a, n+1);
   For i := 1 to n do SetLength(a[i], n+1);

   For i:= 1 to n do 
      For j := 1 to n do Read(a[i][j]);

   For i := 1 to n do
      If (a[i][i] > 0) then begin Inc(kol); ans := ans + a[i][i]; End;

   If (kol > 0) then begin Writeln('Ср. ар. с гл. диагонали = ', ans / kol); kol := 0;ans := 0; End
   Else Writeln('Элементов > 0 на гл. диагонали - нет !');

   For i := 1 to n do
      If (a[i][n-i+1] > 0) then begin Inc(kol); ans := ans + a[i][n-i+1]; End;

   If (kol > 0) then Writeln('Ср. ар. с поб. диагонали = ', ans / kol)
   Else Writeln('Элементов > 0 на поб. диагонали - нет !');
END.
0,0(0 оценок)
Ответ:
oliver9999
23.09.2021 19:18
1.Арфа,балалайка,виолончель,скрипка,флейта. тут все струнные кроме флейты
2.Барка,джонка,рикша,пакетбот,ял. тут все корабли кроме рикши
3.Мусоргский,Моцарт,Тургенев,Чайковский,Бетховен. тут все музыканты кроме тургеньева
4.Брюссель,Лондон,Мадрид,Москва,Нью-Йорк,Оттава,Париж. нью-йорк не столица
5.Бунгало,иглу,офис,хижина,шале. офис не место для проживания
6.Волга,Дунай,Нил,Рейн,Сена. все реки кроме нила текут в европейской части
7."Волга","Жигули","Москвич","Руслан","Чайка".все транспорт руслан самолет
8.Гранит,кварц,мрамор,полевой шпат,торф. торф не является твердой породой
9.Какао,кофе,пальто,резюме,эссе. все среднего рода кофе мужского
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота