Alexa1888
30.10.2022 16:34

Напишите программу в паскале , которая зная секунды, за которые десятиклассник пробежал
2000 метров, а так же его пол, выставляет отметку по этой дисциплине.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
medvedevastasy
13.10.2020 20:31

Объяснение:

var a,b,s,o:integer;

begin

 o := 0;

 writeln('введите количество секунд');

 readln(a);

 writeln('1.муж  2.жен');

 readln(b);

 s:=0;

 if b = 1 then  

 begin

   if (a <= 400) and (s=0) then

     begin

     o := 5;

     s := s+1;

     end;

   if (a <= 500) and (s=0) then

     begin

     o := 4;

     s := s+1;

     end;

   if (a <= 600) and (s=0) then

     begin

     o := 3;

     s := s+1;

     end;

   if (a <= 700) and (s=0) then

     begin

     o := 2;

     s := s+1;

     end;

 end

 else

 begin

   if (a <= 500) and (s=0) then

     begin

     o := 5;

     s := s+1;

     end;

   if (a <= 600) and (s=0) then

     begin

     o := 4;

     s := s+1;

     end;

   if (a <= 700) and (s=0) then

     begin

     o := 3;

     s := s+1;

     end;

   if (a <= 800) and (s=0) then

     begin

     o := 2;

     s := s+1;

     end;

 end;

 writeln('оценка: ',o)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота