Марі2017
12.11.2021 21:11

Написать программу которая вычесляет индэкс массы тела

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vitalikebati
13.10.2020 20:17

import pause

from colorama import Back, Fore, Style

languge = input('Пожайлуста выбери язык.Plese coose languge.Оберіть мову будьласка(ru, ukr, en): ')

if languge == 'ru':

ask = input('Привет я программа которая измеряет соотношение веса и роста.Ну что готов(y / n): ')

if ask == 'n':

 print("Жаль.Пока")

if ask == 'y':

 rost = float(input( 'Введи свой рост в метрах(1.7): '))

 ves = float(input('Введи вес в килограммах: '))

 soothohenie = float( ves / (rost ** 2))

 if soothohenie < 18.5:

  print('Парень(девушка) да ты тощак едь к бабушке она все поправит ¬_¬')

 elif (soothohenie >= 18.5 and soothohenie <=  24.9):

  print('Все ок ^_^')

 elif (soothohenie >= 25.0 and soothohenie <= 29.9):

  print('Беги в зал пока не позно а иначе светит Ожирение 1 степени ╰(‵□′)╯')

 elif (soothohenie >=30.0 and soothohenie <= 34.9):

  print( 'Одна булочка на ночь это ничего говорил он(-а) вот ты теперь Жирдяй 1 степени (っ °Д °;)っ')

 elif (soothohenie >= 35.0 and soothohenie <= 39.9):

  print( '*Фейс палм* ну что доигрался жирдяй 2 степени ⊙﹏⊙∥')

 elif soothohenie > 40:

  print( 'Тебе пульт подать он же на твоем 2 метровом пузе (。・∀・)ノ゙')

if languge == 'ukr':

ask = input('Привіт я програма яка вимірює співвідношення ваги і роста.На що готовий(y / n): ')

if ask == 'n':

 print( "Жаль.Бувай")

if ask == 'y':

 rost = float(input( 'Введи свій зріст в метрах(1,.7): '))

 ves = float(input('Введи вагу в кілограмах: '))

 soothohenie = float( ves / (rost ** 2))

 if soothohenie < 18.5:

  print('Хлопець (дівчина) та ти тощак їдь до бабусі вона все виправить ¬_¬')

 elif (soothohenie >= 18.5 and soothohenie <=  24.9):

  print( 'Все ок ^_^')

 elif (soothohenie >= 25.0 and soothohenie <= 29.9):

  print( 'Біжи в зал поки не пізно а інакше світить Ожиріння 1 ступеня ╰(‵□′)╯')

 elif (soothohenie >=30.0 and soothohenie <= 34.9):

  print('Одна булочка на ніч це нічого говорив він (-а) ось ти тепер жирдяй 1 ступеня (っ °Д °;)っ')

 elif (soothohenie >= 35.0 and soothohenie <= 39.9):

  print( '* Фейс палм * ну що догрався жирдяй 2 ступеня ⊙﹏⊙∥')

 elif soothohenie > 40:

  print( 'Тобі пульт подати він же на твоєму 2 метровому пузі (。・∀・)ノ゙')

if languge == 'en':

ask = input('Hi, I’m a program that measures the ratio of weight to height. Well, what is ready(y / n): ')

if ask == 'n':

 print( "Sorry, bye")

if ask == 'y':

 rost = float(input( 'Enter your height in meters(1.7): '))

 ves = float(input('Enter the weight in kilograms: '))

 soothohenie = float( ves / (rost ** 2))

 if soothohenie < 18.5:

  print( 'Boy (girl), yes you are a fasting man going to grandmother, she will correct everything ¬_¬')

 elif (soothohenie >= 18.5 and soothohenie <=  24.9):

  print( 'All OK ^_^')

 elif (soothohenie >= 25.0 and soothohenie <= 29.9):

  print( 'Run into the hall until it’s a shame, otherwise Obesity of the 1st degree ╰(‵□′)╯')

 elif (soothohenie >=30.0 and soothohenie <= 34.9):

  print( 'One bun for the night, it said nothing (s) here you are now Fatty 1 degree (っ °Д °;)っ')

 elif (soothohenie >= 35.0 and soothohenie <= 39.9):

  print( '* Face palm * well, that got fat 2 degrees ⊙﹏⊙∥')

 elif soothohenie > 40:

  print( 'Give you the remote control, it’s on your 2 meter belly (。・∀・)ノ゙')

pause.seconds(30)

Объяснение:

0,0(0 оценок)
Ответ:
xandar815
13.10.2020 20:17

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

#include <iostream>

using namespace std;

 

int main()

{   setlocale (LC_ALL, "Russian");

   int feets;

   int duyms;

   int funt;

   cout << "Введите рост в футах и дюймах ";

   cin >> feets;

   cin >> duyms;

   cout << "ВВедите вес тела в фунтах ";

   cin >> funt;

   const int duym = 12;

   const double metr = 0.0254;

   const double kilo = 2.2;

   int Duyms = feets*duym+duyms;

   int meters = Duyms*0.0254;

   int Kilogramm = funt/kilo;

   double BMI = Kilogramm /(meters*meters);

   cout <<"Ваш BMI равен: " << BMI;

   return 0;

   

}

Объяснение:

на C ++

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота