Adel3004
23.04.2021 10:53

Написать программу в среде программирования: Дан целочисленный массив с 30 элементами (имя массива присваиваем свое, т.е. как вас зовут). Заполнить их случайными числам в любом диапазоне (диапазоны берете свои, какие захотите), вывести на экран элементы массива в строку

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
rumtum
15.01.2021 02:31

1, 4

Объяснение:

Рассмотрим путь по такому городу, который проходит по каждой улице не более чем по одному разу.

Простое наблюдение: если какая-то площадь не является началом или концом пути, то из неё должно вести чётное число дорог: по одной дороге в город нужно войти, из другой выйти, и так каждый раз.

Значит, в если в городе есть больше двух городов, из которых ведут нечетное число дорог, то его нельзя обойти, пройдя по каждой улице один раз, так что они точно понравились мистеру Фоксу.

На рисунке черным цветом указано число дорог для каждой площади. Получается, что города 1 и 4 мистеру Фоксу понравились. В городах 2 и 3 можно предложить маршрут, который проходит по каждой улице по одному разу: для 2 это, например, АБВАГВ, для 3 АБВГДЕЁЖВЗДИА - так что эти города понравились мистеру Фоксу не так сильно.


На каникулах мистер фокс побывал в нескольких небольших европейских городах. он помнит, что наиболее
0,0(0 оценок)
Ответ:
MigelAlemanValdes
30.08.2021 13:41
Program Project1;

var m:array [0..14] of integer; i:integer;

function IsPositive(a:integer):boolean;
begin
  result:=(a>-1);
end;

procedure work;
var min, max, count:integer;
begin
  count:=0;
  min:=m[0];
  max:=0;
  for i:=0 to 14 do begin
    if IsPositive(m[i]) then begin
      inc(count);
      if m[i]>max then max:=m[i];
      if m[i]<min then min:=m[i];
    end;
  end;
  writeln('MAX: ', max);
  writeln('MIN: ', min);
  writeln('Count: ', count);
end;

begin
  for i:=0 to 14 do begin
    write('n: ');
    readln(m[i]);
  end;

  work;

  readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота