daurmukhtar99
25.09.2022 22:38

напишите программу(Pascal), которая вычисляет произведение первых n членов ряда 1, ½, 1/3, ¼
Количество членов ряда задается во время работы программы (используя цикл с параметром).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
раф15рус
02.01.2020 11:36
Program n;
var
a, b, i: integer;
begin
b:= 0;
for i:=1 to 4 do
  begin
  readln(a);
  if a > b then
  b:=a;
  end;
writeln('Наибольшее: ' + b);
end.

Как это работает?
Объявляются три целочисленные (interger) переменные:
a - вводимое число
b - самое большое число
i - счётчик цикла
После запуска программы переменной b присваивается значение 0 (чтобы было с чем сравнивать при первом значении)
Запускается цикл for с счётчиком i
Каждый раз цикл просит ввести пользователя число (а)
Дальше проверяется условие, если введённое число a больше числа, которое записано как самое большое (if a>b)
Если ведённое число больше, чем самое большое, то переменной b присваивается значение a
И так пока цикл не закончится
Затем выводится переменная b, в которой хранится самое большое из введённых чисел.
0,0(0 оценок)
Ответ:
nafasomf188
08.10.2022 08:53
Главный мой вопрос был бы интернету-человеку - как ты вмещаешь столько информации? Откуда ты все это знаешь и как запоминаешь? Считаешь ли ты себя самым умным и всезнающим человеком? Ставишь ли себя выше всех остальных? Считаешь ли себя незаменимым человеком? А предъявить в обвинения могу тебе (интернет-человек) твою доступность, твои знакомства и связи (начиная с самого маленького возраста). Почему охотно занимаешься разносом самой непроверенной информации и не несёшь за это никакой ответственности.

Даже не знаю ли это Вам. Как то так, на мой лад получилось)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота