rukisha1107
12.02.2022 13:59

§ 18. Практическая работа «Линейные программы»
1. Требуется написать программу, которая складывает два числа и выводит на экран их сумму.
Определите входные данные и результат этого алгоритма.
К какому типу относятся входные данные:
Сколько входных значений у алгоритма?
К какому типу относятся результаты:
Сколько результатов у алгоритма?
Обозначьте именами входные данные и результаты и напишите их на стрелках:

Запишите формулу, которая связывает исходные данные и результат:
Место для ввода текста.
2. Требуется написать программу, которая выводит скорость и времядвижения автомобиля и выводит на экран расстояние, которое он проехал.Определите входные данные и результат этого алгоритма.
К какому типу относятся входные данные:
Сколько входных значений у алгоритма?
К какому типу относятся результаты:
Сколько результатов у алгоритма?
Обозначьте именами входные данные и результаты и напишите их на стрелках:

Запишите формулу, которая связывает исходные данные и результат:
Место для ввода текста.
3. В языке Python целые переменные относятся к типу (классу)int. Выясните, откуда произошло сокращениеint в языках программирования:
int – это сокращение от английского слова , которое переводится как .
4. Выделите красным фономнедопустимые имена переменных:
1 Vasya СУ-27 @mail_ru
m11 Петя СУ_27 lenta.ru
1m Митин брат _27 "Pesbarbos"
m 1 Quovadis СУ(27) <Ладья>
5. Что появится на экране после выполнения программы:
c = 5
print( с )
print( 'c' )
ответ:
Чем отличаются два оператора вывода в программе?
Место для ввода текста.
6. Что выведет на экран программма
a= 1
print( a )
a= 5
print( a ) ответ:
Заполните пропуски: «Если переменной присваивается новое значение, то предыдущее значение .»
Выберите правильный вариант: «Переменнаяв любой момент может иметь ».
7. Чему будут равны значения переменных a и b после выполнения программмы, если вначале они имели значения a = 4 и b = 7? Выполните ручную прокрутку программы.
a b
4 7
a= a + 1
b= b + 1
a= a + b
b= b + a
a= a + 1
ответ: a = b =
8. Что выведет эта программа приa = 4, b = 5иc = 9?
print( 'a','+b',=,c )
Место для ввода текста.
9. Исправьте ошибки в операторе вывода,
print( 'c','-b',=, a )
чтобы при a = 4, b = 5 и c = 9 программа вывела 9–5=4:
Место для ввода текста.
10. Определите порядок действий компьютера при вычислении выражения (впишите номер выполняемого действия над знаком операции):

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
arishatopic
28.04.2023 04:41
Для того что бы округлить нужно использовать "=ОКРУГЛ" данная команда округляет число до указанного количества десятичных разрядов, цифр после запятой. (что бы округлить сумму нужно записывать количество десятичных разрядов в конце выражения). Пример:«=ОКРУГЛ(выражение);число)»

Дано:

Математическое выражение:
«(89+75)−2(72:(3+7))»

Найти:
Значение выражения и округлить его в MS Ecxel.

Формула (Её нужно ввести в окошко Excel и нажать "Enter"):
«=ОКРУГЛ((89+75)-2*(72/(3+7));2)»

ответ:
149,6

(До сотых программа округлить не может, ибо число имеет только десятые в ответе)

Далее скриншот, и файл Excel в котором формула и сам ответ.


Вычисли значение выражения в ms excel: (89+75)−2(72: (3+ (ответ округли до сотых)
0,0(0 оценок)
Ответ:
Vita1968
24.04.2023 19:01
Const n=8;
var x : array[1..n] of real;
   i : integer; min : real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
  x[i]:=20*random-10;
  write(x[i]:6:2,' ');     
 end;
 writeln;
min:=x[1];
for i:=2 to n do
 if x[i] < min then min:=x[i];
writeln('min=',min:6:2);
for i:=1 to n do
 if x[i]<0 then x[i]:=min;
writeln('Измененный массив:');
for i:=1 to n do write(x[i]:6:2,' ');
end.

Пример:
Исходный массив:
 -7.84  -9.97   7.00  -8.26  -7.71  -3.88   7.59  -2.32 
min= -9.97
Измененный массив:
 -9.97  -9.97   7.00  -9.97  -9.97  -9.97   7.59  -9.97 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота