Anonim4ka
27.07.2022 05:43

написать программу , которая подсчитывает сумму натуральных чисел от 1 до n (с циклом for, while, repeat

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tastapva
24.08.2020 01:52

ЦИКЛ FOR:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

for i:=1 to n do

s:=s+i;

writeln('Сумма равна ',s);

end.

ЦИКЛ WHILE:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

i:=1;

while (i<=n) do

begin

s:=s+i;

i:=i+1;

end;

writeln('Сумма равна ',s);

end.

ЦИКЛ REPEAT:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

i:=1;

repeat

s:=s+i;

i:=i+1;

until i>n;

writeln('Сумма равна ',s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота