Daniela04102005
11.06.2020 11:16

Написать программу нахождения суммы элементов массива, заполненного случайными числами

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Makeev20
17.03.2023 02:18

program fantscrin;

  const n = 11;

  var a: array [1..n] of integer;

      i,s,p: integer;

begin

  for i: =1 to n do

    a[i]: = random(8)+4;

  for i: =1 to n do

    write(a[i], '   ');

   

  s: =0;

  p: =1;

  for i: =1 to n do

    if (i mod 2 = 0) then p: =p*a[i]

                    else s: =s+a[i];  

   

  writeln('');

  writeln('сумма = ',s);

  writeln('произведение = ',p);

end.

0,0(0 оценок)
Ответ:
AliceRosen
22.02.2023 06:47

    f(x) = (x^2 -1)/(x^3 -1) = (x-1)(x+1) / (x-1)(x^2+x+1) = (x+1) / (x^2+x+1)  

f(1) = (1+1)/(1^2+1+1)=2/3  

 

но лучше так  

lim(x-> -1)(x^3-1)= lim(x-> 1-) ((x-1)(x+1) / (x-1)(x^2+x+1))=lim(x-> +1) / (x^2+x+1))=2/3  

lim(x-> 1+)(x^2-1)(x^3-1)= lim(x-> 1+) ((x-1)(x+1) / (x-1)(x^2+x+1))=lim(x-> 1++1) / (x^2+x+1))=2/3  

получаем, что x=1 - точка разрыва 1-го рода,  

но так как f(1-)=f(1+) - разрыв устранимый, потому что f(x) становится непрерывной, если положить f(1)=f(1-0)=f(1+0)=2/3

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота