Кристина6965
07.01.2023 21:13

1) Написать программу, которая вводит натуральное число N и выводит первые N натуральных чисел.
2) Написать программу, которая вводит натуральные числа А и В, и выводит квадраты натуральных чисел в диапазоне от А до В.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dasha1949
13.10.2020 19:21

1 программа:

var a, i:integer;

begin

write('Введите натуральное число: ');

readln(a);

if (a <= 0) then

writeln('Ошибка')

else begin

for i:=1 to a do

  writeln(i);

end;

end.

2 программа:

var a, b, i:integer;

begin

write('Введите 1 число: ');

readln(a);

if (a < 0) then

 writeln('Ошибка')

else begin

 write('Введите 2 число: ');

 readln(b);

 if (b < 0) then

   writeln('Ошибка')

 else begin

   for i:=a to b do begin

   writeln(i*i);

end;

end;

end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота