Грызина
14.01.2020 01:45

Задача №1 Выполнить трассировку (прогон) программы и определить, что будет выведено на экран после выполнения фрагмента программы. ( )

……

Begin

А:=1;

For С:=10 downto 5 do

Begin

A:=A+C;

End;

Writeln (‘Значение A=’, A);

End.

Задача №2 Выполнить трассировку (прогон) программы и определить, чему будет равно значение переменной b после выполнения фрагмента программы. ( )

……

Begin

b:=0;

For k:=2 to 3 do

Begin

For i:=1 to 2 do

b:=b+2*i*k;

End;

End;

b:=sqr (b);

Writeln (‘b=’, b);

End.

Задача №3 Выполнить трассировку (прогон) программы и определить, чему будет равно значение переменной X и S после выполнения фрагмента программы. ( )

……

Begin

S:=0; X:=10; A:=0; B:=0;

For i:=1 to 3 do

Begin

S:=S+2*i;

if X>=6 then X:=X / 2

else X:=X*6;

End;

if S
S:=Dec (S);

X:=Inc(X);

End;

Writeln (‘X=’, X);

Writeln (‘S=’, S);

End.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DanilVenstor
13.10.2020 18:34

1)46

2)900

3) прогон третьей невозможен, так как переменная S имеет тип real, а в строке if S её используют, как Boolean

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота