lowrentij
24.07.2021 05:17

Программирование Напишите программу для Паскаль.
Вам необходимо написать программу для вычисления функции cos x , задать разные углы и сравнить результат с калькулятором.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
margusqw
03.02.2021 07:05
Судя по всему, здесь в цикле складываются квадраты всех нечетных чисел от m до n включительно.

m & 1 - это битовая конъюнкция. Результатом будет 1, если m нечетное, и 0, если m - четное (то есть, содержит или не содержит соответствующий разряд)

Выражение вида T ? X : Y, где T - логическое высказывание, принимает значение X, если T истинно, и Y, если T ложно.

Соответственно, i = (m & 1) == 1 ? m : m + 1 означает, что
если m нечетное, то i = m
если четное, i = m+1 (то есть, первое нечетное число после m)

i += 2 означает, что цикл идет с шагом, соответственно, рассматриваются только нечетные числа.
0,0(0 оценок)
Ответ:
виталий146
08.04.2022 19:57

#include "pch.h"

#include

#include

using namespace std;

double f(double x)

{

double m = -7 * pow(x, 3) - 5.8*x - 4;

return m;

}

int main()

{

double a = -1; double b = 2;

flag1:

double c = 0.5*(a + b);

if (f(c) == 0)

cout << "The result is " << c << endl;

if (f(c)*f(a) < 0)

{

b = c;

goto flag1;

}

if (f(c)*f(b) < 0)

{

a = c;

goto flag1;

}

if (c >= a && c <= b)

cout << "The solution belongs to the interval" << endl;

else

cout << "The solution doesn't belongs to the interval";

return 0;

}

Тут с флагами. Если не нравятся флаги - перестройте под себя.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота