sxxaaa
18.05.2023 21:22

Напишите программу(Паскаль) по данной блок схеме.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Яяяяя11111111
15.12.2022 03:30
Const
  n=15;
var
  i,np,nn,amax:integer;
  a:array[1..n] of integer;
begin
  Randomize;
  Write('Исходный массив: ');
  np:=0; nn:=0;
  for i:=1 to n do begin
    a[i]:=Random(51)-15;
    Write(a[i],' ');
    if a[i]>0 then Inc(np)
    else if a[i]<0 then Inc(nn);
    end;
  Writeln;
  if np/nn>2 then begin
    amax:=a[i];
    for i:=2 to n do
      if a[i]>amax then amax:=a[i];
    Write('Выходной массив: ');
    for i:=1 to n do begin
      if a[i]<0 then a[i]:=1
      else
        if a[i]>0 then a[i]:=a[i]*amax;
      Write(a[i],' ')
      end;
    Writeln
    end
  else Writeln('В массив изменения не вносятся')
end.

Пример работы программы
Исходный массив: 28 8 21 32 0 26 30 11 35 21 14 6 0 -4 -8
Выходной массив: 980 280 735 1120 0 910 1050 385 1225 735 490 210 0 1 1
0,0(0 оценок)
Ответ:
belokurserezhe
14.06.2020 03:19
ЛЛЛЛ ,ЛЛЛЕ ,ЛЛЛТ ,ЛЛЛО ,ЛЛЕЛ ,ЛЛЕЕ ,ЛЛЕТ ,ЛЛЕО ,ЛЛТЛ ,ЛЛТЕ ,ЛЛТТ ,ЛЛТО ,ЛЛОЛ ,ЛЛОЕ ,ЛЛОТ ,ЛЛОО ,ЛЕЛЛ ,ЛЕЛЕ ,ЛЕЛТ ,ЛЕЛО ,ЛЕЕЛ ,ЛЕЕЕ ,ЛЕЕТ ,ЛЕЕО ,ЛЕТЛ ,ЛЕТЕ ,ЛЕТТ ,ЛЕТО ,ЛЕОЛ ,ЛЕОЕ ,ЛЕОТ ,ЛЕОО ,ЛТЛЛ ,ЛТЛЕ ,ЛТЛТ ,ЛТЛО ,ЛТЕЛ ,ЛТЕЕ ,ЛТЕТ ,ЛТЕО ,ЛТТЛ ,ЛТТЕ ,ЛТТТ ,ЛТТО ,ЛТОЛ ,ЛТОЕ ,ЛТОТ ,ЛТОО ,ЛОЛЛ ,ЛОЛЕ ,ЛОЛТ ,ЛОЛО ,ЛОЕЛ ,ЛОЕЕ ,ЛОЕТ ,ЛОЕО ,ЛОТЛ ,ЛОТЕ ,ЛОТТ ,ЛОТО ,ЛООЛ ,ЛООЕ ,ЛООТ ,ЛООО ,ТЛЛЛ ,ТЛЛЕ ,ТЛЛТ ,ТЛЛО ,ТЛЕЛ ,ТЛЕЕ ,ТЛЕТ ,ТЛЕО ,ТЛТЛ ,ТЛТЕ ,ТЛТТ ,ТЛТО ,ТЛОЛ ,ТЛОЕ ,ТЛОТ ,ТЛОО ,ТЕЛЛ ,ТЕЛЕ ,ТЕЛТ ,ТЕЛО ,ТЕЕЛ ,ТЕЕЕ ,ТЕЕТ ,ТЕЕО ,ТЕТЛ ,ТЕТЕ ,ТЕТТ ,ТЕТО ,ТЕОЛ ,ТЕОЕ ,ТЕОТ ,ТЕОО ,ТТЛЛ ,ТТЛЕ ,ТТЛТ ,ТТЛО ,ТТЕЛ ,ТТЕЕ ,ТТЕТ ,ТТЕО ,ТТТЛ ,ТТТЕ ,ТТТТ ,ТТТО ,ТТОЛ ,ТТОЕ ,ТТОТ ,ТТОО ,ТОЛЛ ,ТОЛЕ ,ТОЛТ ,ТОЛО ,ТОЕЛ ,ТОЕЕ ,ТОЕТ ,ТОЕО ,ТОТЛ ,ТОТЕ ,ТОТТ ,ТОТО ,ТООЛ ,ТООЕ ,ТООТ ,ТООО

Всего: 128


var
  a : array [1..4] of char;
  i, k, l, m, N : byte;
begin
  a[1] := 'Л'; a[2] := 'Е'; a[3] := 'Т'; a[4] := 'О';
  for i := 1 to 3 do begin
    for k := 1 to 4 do begin
      for l := 1 to 4 do begin
       for m := 1 to 4 do begin
         if i <> 2 then begin write(a[i], a[k], a[l], a[m], ' ,'); N += 1; end;
        end;
      end;
    end;
  end;
    writeln('Всего: ', N)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота