Вилетта2006
19.04.2020 23:29

Написать программу по информатике языком С++ по этим задачам. мне надо

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alena667
29.04.2022 23:53
Var
i,j,k:longint;
    begin
         for i:=1 to 1000 do
              for j:=1 to 1000 do       
                   for k:=1 to 10000 do             
                      if sqr(i)+sqr(j)=sqr(K)then               
                           begin                 
                                writeln(i,' ',j,' ',k);  {вывожу все тройки, можно убрать}             
                                     if i+j+k=1000 then                 
                                          begin                 
                                               writeln('! ',i,' ',j,' ',k);  {нужная тройка}                
                                                exit; {прерывание программы}                
                                          end;               
                           end;   
     end.


Существуют тройки пифагора, то есть a^2+b^2=c^2 . есть лишь одна такая тройка, что a+b+c=1000 . напи
0,0(0 оценок)
Ответ:
duyquhuseynli11
03.10.2021 18:12
Type
  sc=record
    name:string;
    fam:string;
    age:byte;
    school:integer;
    clas:string
  end;
var
  i,n:integer;
  a:array[1..10] of sc;
  f:Text;
begin
  Writeln('Читаем данные из файла input.txt');
  Assign(f,'input.txt'); Reset(f);
  n:=0;
  while (not Eof(f)) and (n<10) do begin
    Inc(n);
    Readln(f,a[n].fam); Readln(f,a[n].name);
    Readln(f,a[n].age); Readln(f,a[n].school);
    Readln(f,a[n].clas)
  end;
  Close(f);
  Writeln('Принято записей: ',n);
  Writeln('Контрольный вывод');
  for i:=1 to n do
  begin
    Writeln('Школьник ',i,':');
    Write(a[i].name,' ',a[i].fam,', ');
    Write(a[i].age,' лет, школа №',a[i].school);
    Writeln(', класс ',a[i].clas)
  end
end.

Тестовое решение:
Читаем данные из файла input.txt
Принято записей: 3
Контрольный вывод
Школьник 1:
Иванов Иван, 14 лет, школа №126, класс 7б
Школьник 2:
Петров Петр, 13 лет, школа №18, класс 6а
Школьник 3:
Семенова Валентина, 15 лет, школа №52, класс 8г

Файл input.txt для тестового решения находится во вложении.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота