kozlovadasa52
02.02.2021 02:13

Даны три точки в прямоугольной системе координат. Напишите программу, определяющую, которая из первых двух точек находится ближе к третьей точке.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
djhvh235
28.01.2023 01:24

program ExampleN;

uses Math;   // объявление математических функций для вашей версии паскаля

var

 a, b, d, s, y1, y2, x: Double;

begin

 Write ('Введете границы отрезка: ');

 ReadLn (a, b);

 s := 0;

 d := (b - a) / 10;             // длина 1/10 отрезка

 x := a + d / 2;                // начальное значение Х = левая граница + половина отрезка (середина основания)

 while x < b do begin           // цикл по всей длине отрезка

   y1 := Sqr (x);

   y2 := 5 + x / 2;

   s := s + Abs (y1 - y2) * d;  // расчет площади прямоугольника и суммирование

   x := x + d;                  // увеличение Х на 1/10 отрезка

 end;

 WriteLn ('Площадь = ', s :20 :10);

 ReadLn;

end.

0,0(0 оценок)
Ответ:
Den3801
28.01.2023 01:24

bank_ques = {}

#Создание вопросов:

# bank_ques["сам вопрос"'] = "ответ на него", вопрос и ответ в виде строки, даже если это число

bank_ques["2*2"] = "4"

bank_ques["3*3"] = "9"

bank_ques["4*4"] = "16"

bank_ques["5*5"] = "25"

bank_ques["6*6"] = "36"

#Вопросов может быть неограниченное количество

# Также генерировать вопросы можно как в самом коде, так и сделать в цикле, но тут уже как хотите

for question in bank_ques:

   print(question)

   answer = input("ответ: ")

   if answer == bank_ques[question]:

       print("правильно")

   else:

       print("ответ неверный")

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота