Yaryycher
30.03.2021 16:11

Дан массив, содержащий 2018 положительных целых чисел, не превышающих 30 000. Необходимо найти в этом массиве количество элементов, которые кратны 3, а их десятичная запись заканчивается цифрой 1, и заменить каждый из таких элементов на это количество. Напишите программу для решения этой задачи. В качестве результата программа должна вывести изменённый массив, по одному элементу в строке. Например, для исходного массива из 5 элементов

15 71 21 111 41

программа должна вывести (по одному числу в строке) числа

15 71 2 2 41.

#include
using namespace std;
const int N = 2018;
int main() {
int a[N];
int i, k, s;
for (i = 0; i cin >> a[i];
...
return 0;
}
Требуется дописать программу используя язык C++ и те же константы

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sergooopoop
29.08.2020 20:46
Var
    a: array[0..10] of integer;
    i, n, k: integer;
//    b: array[1..4, 1..4] of integer;

begin
    Println();
    Println(1);
    for i := 0 to 10 do
        A[i] := i + 1;
    PrintLn(a);
    Println();
    for i := 1 to 10 do
    begin
        A[i] := A[i - 1];
        PrintLn(a);
    end;
    
    Println();
    Println(2);
    for i := 0 to 10 do
        A[i] := i + 1;
    PrintLn(a);
    Println();
    for i := 10 downto 0 do
    begin
        A[i] := A[10 - i];
        PrintLn(a);
    end;
end.

Тут вывод трасировок последних циклов

1
[1,2,3,4,5,6,7,8,9,10,11]

[1,1,3,4,5,6,7,8,9,10,11]
[1,1,1,4,5,6,7,8,9,10,11]
[1,1,1,1,5,6,7,8,9,10,11]
[1,1,1,1,1,6,7,8,9,10,11]
[1,1,1,1,1,1,7,8,9,10,11]
[1,1,1,1,1,1,1,8,9,10,11]
[1,1,1,1,1,1,1,1,9,10,11]
[1,1,1,1,1,1,1,1,1,10,11]
[1,1,1,1,1,1,1,1,1,1,11]
[1,1,1,1,1,1,1,1,1,1,1]

2
[1,2,3,4,5,6,7,8,9,10,11]

[1,2,3,4,5,6,7,8,9,10,1]
[1,2,3,4,5,6,7,8,9,2,1]
[1,2,3,4,5,6,7,8,3,2,1]
[1,2,3,4,5,6,7,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
0,0(0 оценок)
Ответ:
zero161
29.08.2020 20:46
Все элементы будут равны единице.
Сначала они будут заполнены значением, большим своего индекса на 1, а потом каждому элементу, начиная со второго (который А[1]) будет присвоено значение предыдущего элемента и 1 распространится везде.

Для проверки была написана программа с отладочной выдачей.

var
  a:array[0..10] of integer;
  i:integer;
begin
  for i:=0 to 10 do begin a[i]:=i+1; Write(a[i],' ') end;
  Writeln;
  Write(a[0],' ');
  for i:=1 to 10 do begin a[i]:=a[i-1]; Write(a[i],' ') end
end.

Результаты

1 2 3 4 5 6 7 8 9 10 11
1 1 1 1 1 1 1 1 1 1 1

ответ: 3)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота