lybchikfreed
06.10.2020 02:13

за решение через for
Напишите программу, которая запрашивает число N, а затем считает сумму чисел от 1 до N включительно, т.е. 1+2+3...+N.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lala0911
13.10.2020 14:25

уточняйте на каком языке программирования нужно написать.

Для примера напишу на С++, но алгоритм будет тот же везде

//Создаем переменные n и sum

int n = 0;

int sum = 0;

//Вводим число n с клавиатуры.

cout << "Введите n: ";

cin >> n;

//Создаём цикл от 0 к числу которое мы ввели(включая его)

//Считаем сумму всех чисел которые идут до этого числа

for(int i = 0; i<=n; i++){

sum = sum + i;

}

//Выводим нашу сумму

cout << "Сумма: " << sum;

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота