DashaV19022001
01.07.2020 12:55

Напишите программу, которая запрашивает число N, а затем считает сумму чисел от 1
до N включительно, т.е. 1+2+3...+N

Через Pascal и For

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
JeanSu
27.05.2022 11:20
Народ последнюю задачку проверьте опять не могу найти ошибку
УСЛОВИЕ:
Дано натуральное четырехзначное число. Найти наименьшую нечетную цифру в числовой записи данного числа.
Формат входных данных
Входной файл содержит натуральное четырехзначное число.
Формат выходных данных
Выведите наименьшую нечетную цифру в числовой записи данного числа. Если нечетных цифр в числе нет, выведите в выходной файл -1.

РЕШЕНИЕ:
PascalВыделить код1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 var n,a,b,c,d:integer; f,g:text; begin assign(f,'input.txt'); assign(g,'output.txt'); reset(f); rewrite(g); readln(f,n); a:=n div 1000; b:=n div 100 mod 10; c:=(n mod 100) div 10; d:=n mod 10; if (a mod 2=0) and (b mod 2=0) and (c mod 2=0) and (d mod 2=0) and (n<>0)  then writeln(g,'-1') else if (a<=b) and (a<=c) and (a<=d) then writeln(g,a) else if (b<=a) and (b<=c) and (b<=d)then  writeln(g,b) else if (c<=a) and (c<=b) and (c<=d) then writeln(g,c) else if (d<=a) and (d<=b) and (d<=c) then writeln(g,d) else close(f); close(g); end.
0,0(0 оценок)
Ответ:
Dimasik333000
21.11.2021 06:14
Язык программирования не указан, потому - самый простой вариант - программа на паскале. Даже на паскале задачу можно решать различными с массивом, без массива, со строками, без строк. Опять-таки, самый простой вариант - со строками.
var s,p:string; n,i:integer;
begin
writeln('Введите символы:');
readln(s);
n:=pos('.',s)-1;
writeln('n = ',n);
p:='';
for i:=1 to n do p:=s[i]+p;
writeln('а)');
writeln(p);
p:='';
if n mod 2 = 0 then i:=2 else i:=1;
while i<=n do
 begin
 p:=p+s[i];
 i:=i+2;
 end;
writeln('б)');
writeln(p);
end.

Пример:
Введите символы:Даны символы s1, s2, ... Известно, что символ s1 отличен от точки
n = 21
а)
 ,2s ,1s ыловмис ынаД
б)
Дн ивл 1 2 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота