олегБро666
18.05.2021 17:13

Напишите программу анимации в паскале.
Круг перекатывающийся с окна в окно не подойдет
Светофор и солнечная система тоже

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
7Таяна
09.08.2020 12:45

1-ый

uses graphabc,crt;

var i:integer; h:real;

begin

randomize;

rectangle(280,130,320,320);

rectangle(250,10,350,260);

circle(300,55,35);

circle(300,135,35);

circle(300,215,35);

for i:=1 to 1000 do

begin

floodfill(300,55,clred);

delay(3000);

floodfill(300,55,clwhite);

delay(1000);

floodfill(300,135,clyellow);

delay(3000);

floodfill(300,135,clwhite);

delay(1000);

floodfill(300,215,clgreen);

delay(1000);

floodfill(300,215,clwhite);

delay(1000);

end;

end.

2-ой

Program Svetofor;

Uses crt;

var c:1..3;

begin clrscr;

randomize;

writeln('переход по сигналу светофора');

c:=random (3)+1;

gotoxy(35,11);

case c of

1:begin textcolor (red); writeln ('красный-стой!');end;

2:begin textcolor (yellow); writeln('желтый-приготовься!');end;

3:begin textcolor (green); writeln('зеленый-иди!');end;

end;

sleep(3000);

until keypressed;

End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота