Halimedy
30.06.2022 00:22

Напишите программу, которая выводит в левом верхнем углу экрана
квадрат, изображенный с использованием символа, который пользователь
введет с клавиатуры (размер квадрата 3x3 символа). По нажатию любой
клавиши выводится еще один такой же квадрат со смещением на 5
позиций вправо. При следующем нажатии любой клавиши выводится
такой же квадрат на 5 строк ниже, чем первый квадрат.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KristinkaVayyyys
17.04.2021 18:01
Технология мультимедиа положена в основу создания всевозможных мультимедийных продуктов, характерными особенностями которых являются:
- объединение в одном продукте текстовой, графической, аудио-, видеоинформации, анимаций;
- наличие интерактивного (диалогового) режима работы;
- возможность быстрого поиска информации;
- широкие возможности навигаций;
- возможность работы в реальном времени, в замедленном или в ускоренном темпе;
- дружественный пользовательский интерфейс.
Например, в компьютерной игре задействованы графика и аудиоинформация.
0,0(0 оценок)
Ответ:
тима400
07.03.2020 06:46

#

# https://pastebin.com/Nasemc0T

#

# Python 3.x

# 1.

# Для теста возьмем конкретную матрицу 8x8.

matrix=[[-35, 115, -45, -25, 1, 83, 13, 53], [119, 128, 31, 124, 66, 126, 63, -1], [-21, 86, 120, 68, 149, 65, -42, 107], [108, 112, 96, 25, 99, 9, 140, 89], [51, 99, 68, 80, 26, 74, 105, -6], [92, 82, 22, 54, 11, 87, -2, -42], [26, -21, 129, 85, 97, 101, 106, 96], [10, -7, -28, 96, 115, 57, -25, 77]]

# Эквивалентно .flatten() для numpy матрицы.

array=list()

for row in matrix: array=array + row

maximum=max(array)

print("#1. Maximum: ", maximum)

# 2.

file="test.txt"

with open(file) as fp:

amount=int(fp.readline())

array=list()

for _ in range(amount):

 digit=int(fp.readline())

 array.append(digit)

 # конец двойно табуляции

maximum=max(array)

print("#2. Maximum: ", maximum)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота