ilyassovaalina235393
20.04.2023 16:11

7. На вход программе подается натуральное число. Каких цифр в числе больше четных или нечетных. В ответ выведите 1, если больше нечетных и 0, если четных и 2, если их количество одинаково.Питон

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nikgali
13.10.2020 14:35

num = input()

n = len(num)

odd = 0

noodd = 0

while i < len(num):

   if(int(num[i]) % 2 == 0):

       odd = odd + 1

   else :

       noodd = noodd + 1

if(odd == noodd):

   print(2)

elif(odd > noodd):

   print(0)

else :

   print(1)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота