sereg1525
28.01.2022 06:44

Напишите программу для заполнения массива случайными числами от -40 до 40 и вывод на экран отрицательных чисел.
Паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
leetine7
13.10.2020 15:06

1. var

a:array[1..7] of integer;

i:Integer;

begin

//заполнение массива

a[1]:=3;

a[2]:=8;

a[3]:=2;

a[4]:=0;

a[5]:=2;

a[6]:=1;

a[7]:=7;

//вывод массива

for i:=1 to 7 do

Writeln(a[i]);

end.

2. var

c:array[1..12] of integer;

i:Integer;

begin

//заполнение массива

for i:=1 to 12 do

begin

Writeln('Введите ',i,' элемент массива');

readln(c[i]);

end;

//вывод массива

Writeln('Массив');

for i:=1 to 12 do

Write(c[i],' ');

end.

3.var

s:array[1..15] of integer;

i:Integer;

begin

//заполнение массива

for i:=1 to 15 do

s[i]:=random(40);

//вывод массива

Writeln('Массив');

for i:=1 to 15 do

Write(s[i],' ');

end.

4.var

b:array[1..25] of Real;

i:Integer;

begin

//заполнение массива

b[1]:=3;

b[2]:=6;

for i:=3 to 25 do

b[i]:=(b[i-1]+b[i-2])/i;

//вывод массива

Writeln('Массив');

for i:=1 to 25 do

Write(b[i]:9:3);

end.

Подробнее - на -

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота