nikitacRon
11.03.2020 01:53

Решить на языке Паскаль!
1. Заполнить массив из 20 чисел случайными значениями в диапазоне от -40 до 40. Вывести на экран данный массив в строку и количество четных чисел.
2. Написать программу,которая в одномерном массиве из 10 чисел находит максимальны и минимальный элемент.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alievaaytan17
08.06.2023 09:58
1) Решение методом рекурсии.
Программа проста в понимании, но неэффективна при больших значениях
var
  n: integer;
function f(i: integer): longint;
begin
  if i < 2 then
    f := 1
  else
    f := f(i - 1) + f(i - 2);
end;
begin
  read(n);
  writeln(f(n));
end.

2) Решение методом динамического программирования. Намного быстрее метода с рекурсией.
var
  i, n: integer;
  f: array[0..50] of longint;
begin
  read(n);
  f[0] := 1;
  f[1] := 1;
  for i := 2 to n do
    f[i] := f[i - 1] + f[i - 2];
  writeln(f[n]);
end.

3) Решение методом моделирования. Использует меньше памяти.
var
  n, a, b, i: integer;
begin
  read(n);
  if n < 2 then
    a := 1
  else
  begin
    a := 0;
    b := 1;
    for i := 0 to n do
    begin
      b := a + b;
      a := b - a;
    end;
  end;
  writeln(a);
end.
0,0(0 оценок)
Ответ:
664565465
19.08.2020 19:37
9 килобайт = 9216 байт.
Зная информационный объём рассказа и количество страниц, найдём информационный объём одной страницы. В условии сказано, что каждый символ кодируется 8 битами, т.е. одним байтом. Также мы знаем количество символов в одной строке. Умножив 1 байт на количество символов в строке, найдём информационный объём одной строки. И, наконец, разделив информационный объём страницы на информационный объём строки, найдём количество строк на странице.

1) 9216 : 6 = 1536 (байт) – информационный объём одной страницы.

2) 1 × 48 = 48 (байт) – информационный объём одной строки.

3) 1536 : 48 = 32 (стр.) – количество строк на каждой странице.

ответ: на каждой странице помещается 32 строки.

ПРАВИЛЬНЫЙ ОТВЕТ – 3) 32
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота