maksim446681
16.10.2020 19:59

Даны стороны прямоугольника a и b. Напишите программу вычисления его площади (Ввод значений a и b организовать с генератора случайных чисел. Выводить значения a, b, S)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
SovaUtuber
05.06.2021 09:44
Ультразвуковой датчик-это специальный инструмент, используемый для измерений в промышленной автоматизации. С его можно измерять расстояние, высоту и уровень, а также определять положение в пространстве, обнаруживать наличие объектов и даже подсчитывать их по отдельности.
Ультразвуковые датчики содержат ультразвуковые преобразователи . Преобразователь может преобразовывать одну форму энергии в другую. Датчик является причиной, по которой датчик может излучать звуковой импульс. Затем создается эхо, когда излучаемый импульс отражается от объекта.
0,0(0 оценок)
Ответ:
Рад1111111
06.10.2021 16:34
Добрый день! К сожалению я не работаю с C++, но если это то вот эта задача в Pascal
VAR a,b,c,d:REAL;
PROCEDURE Print_S(x,y,z:REAL);
 VAR  p,S:REAL;
 begin  If ((x+y)>z) and ((x+z)>y) and ((y+z)>x) then 
 begin   
p:=x+y+z;
S:=SQRT(p*(p-x)*(p-y)*(p-z));
WriteLn('S= ',S);
end
 else
Writeln('Треугольник не существует!');
end;
BEGIN Write('a= ');
ReadLn(a);
 Write('b= ');
 ReadLn(b);
 Write('c= ');
 ReadLn(c);
 Write('d= ');
 ReadLn(d);
 WriteLn;
 WriteLn('Стороны ',a,'; ',b,'; ',c);
 Print_S(a,b,c);
 WriteLn;
 WriteLn('Стороны ',a,'; ',b,'; ',d);
 Print_S(a,b,d);
 WriteLn;
 WriteLn('Стороны ',a,'; ',c,'; ',d); 
Print_S(a,c,d);
 WriteLn;
 WriteLn('Стороны ',b,'; ',c,'; ',d);
 Print_S(b,c,d);
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота