напишите программу в паскале с массивами: Дан целочисленный массив из n элементов, все элементы которого – целые числа. Найти среднее арифметическое всех положительных элементов массива, которые кратны первому элементу.
Program project1; uses crt,math; var s:real; i,j,f:real; a:integer; begin writeln('vvedite 1 chislo ');readln(i); writeln('vvedite 2 chislo ');readln(j); writeln('vvedite 3 chislo ');readln(f); s:=i; if j<s then s:=j; if f<s then s:=f; if s<0 then begin if i<0 then inc(a); if j<0 then inc(a); if f<0 then inc(a); writeln('kolichestvo otricatelnix ',a:2); end else begin if i>0 then i:=i*-1; if j>0 then j:=i*-1; if f>0 then f:=i*-1; end; writeln('min chislo ',s:2:0); readln; end.
a,b:integer; d:string[45]; begin SetConsoleOutputCP(1251); writeln('Введите число в диапазоне от 1 дo 100'); write('a='); readln(a); b:=a mod 10; a:=a div 10; case b of 0: d:=''; 1: d:='I'; 2: d:='II'; 3: d:='III'; 4: d:='IV'; 5: d:='V'; 6: d:='VI'; 7: d:='VII'; 8: d:='VIII'; 9: d:='IX'; end; b:=a mod 10; a:=a div 10; case b of 0: d:=''+d; 1: d:='X'+d; 2: d:='XX'+d; 3: d:='XXX'+d; 4: d:='XL'+d; 5: d:='L'+d; 6: d:='LX'+d; 7: d:='LXX'+d; 8: d:='LXXX'+d; 9: d:='XC'+d; end; b:=a mod 10; a:= a div 10; case b of 0: d:=''+d; 1: d:='C'+d; end; writeln('B Римской системе счисления ' ,d); readln; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку