bachko2012
11.01.2022 18:43

координаты точки на прямой. Напишите программу, определяющую расстояние
(r) между этими точками (r=|a-b|) и координату середины отрезка - С)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
жандос29
14.04.2022 05:53
Как-то так:

(+ на скрине результат работы)

#include <iostream>

using namespace std;

int main()

{

   int counter = 0;

   int size = 10;

   int* arr = new int[size]; // создание масива размера size

   for(int i = 0; i < size; i ++) // заполнение и вывод масива

   {

       arr[i] = i - 5;

       cout << arr[i] << " ";

   }

   cout << "\n\n";

   for(int i = 0; i < size; i ++)

   {

       if(arr[i] < 0 && arr[i] % 2 == 0)

       {  

           counter++;

           arr[i] = 665;

       }

       cout << arr[i] << " "; // вывод измененного масива

   }

   cout << "\nAmount = " << counter;  

   return 0;

}


ЯЗЫК C++ Підрахувати кількість парних від’ємних елементів масиву та присвоїти їм значення 665
0,0(0 оценок)
Ответ:
vadimkor06
28.02.2021 06:24

sugarMass=50 #масса сахара

sugarCost=15 #стоимость сахара

flourMass=100 #масса  муки

flourCost=8 #стоимость муки

meatMass=12 #масса мяса

meatCost=95 #стоимость мяса

fishMass=20 #масса рыбы

fishCost=70 #стоимость рыбы

totalCost=sugarMass*sugarCost+flourMass*flourCost+meatMass*meatCost+fishMass*fishCost #общая стоимость  

totalMass=sugarMass+flourMass+meatMass+fishMass #общая масса  

print('Общая стоимость товара - ' + str(totalCost) + 'грн')

print('Общая масса товара - ' + str(totalMass) + 'кг')

print('Стоимость сахара - '+str(sugarMass*sugarCost)+'грн')

print('Стоимость муки - '+str(flourMass*flourCost)+'грн')

print('Стоимость мяса - '+str(meatMass*meatCost)+'грн')

print('Стоимость рыбы - '+str(fishMass*fishCost)+'грн')

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота