Палина200413
02.09.2021 18:07

Программа паскаль.
написать программу:
имеется целочисленный массив из 100 элементов
1) вывести на экран через запятую все элементы имеющие чётный индекс;
2) вывести на экран построчно все элементы имеющие нечётный индекс.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kmurtazalieva72
13.10.2020 13:50

var anarray: array[1..100] of integer;

   i: integer;

begin

   Randomize;

   for i := 1 to 100 do // заполняем массив рандомными числами

       anarray[i] := random(100);

   for i := 1 to 100 do // выводим на экран элементы массива с четным индексом

   begin

       if (i + 1 > 100) then Write(anarray[i])

       else

           if (i mod 2 = 0) then Write(anarray[i], ', ');

   end;

   for i := 1 to 100 do // выводим на экран элементы массива с нечетным индексом

       if (i mod 2 <> 0) then WriteLn(anarray[i]);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота