SlowMoe
01.04.2023 07:57

С решением (питон)
1) В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен фрагмент программы, обрабатывающей данный массив:

s = 0

n = 10

for i in range(0,n-1):

s = s + A[i] - A[I + 2]

В начале выполнения этого фрагмента в массиве находились трёхзначные натуральные числа. Какое наибольшее значение может иметь переменная s после выполнения данной программы?

2) В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6; 9; 7; 2; 1; 5; 0; 3; 4; 8 соответственно, т.е. A[0] = 6; A[1] = 9 и т.д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

c = 0

for i in range(1, 10):

if A[i-1] < A[i]:

c = c + 1

t = A[i]

A[i] = A[i-1]

A[i-1] = t

3) В программе используется одномерный целочисленный массив A с индексами от 1 до 25. Ниже представлен фрагмент программы, в котором задаются значения элементов:

n = 25

A[1]= 2

for i in range(2, n+1):

A[i] = 2*A[i–1] % 10

Чему будет равно значение A[25] после выполнения фрагмента программы?

4) Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести минимальное значение среди элементов массива, которые имеют чётное значение и не делятся на три. Гарантируется, что в исходном массиве есть хотя бы один элемент, значение которого чётно и не кратно трем.

Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но использовать все описанные переменные не обязательно.

# допускается также

# использовать две

# целочисленные переменные j и m

a = []

n = 20

for i in range(0, n):

a.append(int(input()))

...

5) Дан целочисленный массив из 30 элементов. Элементы массива могут принимать натуральные значения от 1 до 10000 включительно. Найти количество элементов массива, сумма цифр которых кратна 5, а затем заменить каждый такой элемент на количество таких элементов. Гарантируется, что хотя бы один такой элемент в массиве есть. В качестве результата необходимо вывести изменённый массив, каждый элемент выводится с новой строчки.
Например, для исходного массива из шести элементов:

1121 3002 50 5 33 27

программа должна вывести следующий массив

4 4 4 4 33 27

Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать некоторые из описанных переменных.

# допускается также

# использовать две

# целочисленные переменные j, k, s

a = []

n = 30

for i in range(0, n):

a.append(int(input()))

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
StarAl73
08.04.2020 09:13

                   

using System;

namespace ConsoleApplication1

{  

  class Program

  {

      public static void Main(string[] args)

      {

          Random random = new Random();

          int n = 4;

          int[,] A = new int[n, n];

          for (int i = 0; i < n; i++)

          {

              for (int j = 0; j < n; j++)

              {

                  A[i, j] = random.Next(0, 100);

              }

          }

          int max = A[n-1, 0];

          for (int i = 0; i < n; i++)

          {

              for (int j = 0; j < n; j++)

              {

                  if (i+j==n-1)

                  {

                      if (max < A[i, j])

                      {

                           

                          max = A[i, j];

                      }

                  }

                   

              }

          }

          Console.WriteLine(max);

      }

  }

}

0,0(0 оценок)
Ответ:
Agartala236
07.10.2021 08:36

1. Microsoft Excel - это...

d) прикладная программа, предназначенная для хранения, обработки данных в виде таблицы

2. Электронная таблица представляет собой:

с) совокупность нумерованных строк и поименованных буквами латинского алфавита столбцов.

3. С каких команд можно запустить программу Excel?

а) Пуск – Программы – Microsoft Office – Microsoft Office Excel

4. Как называется объект обработки в программе Excel?

b) книга

5. Что нужно сделать для создания новой книги в программе Excel?

b) выполнить команду Создать в меню Файл;

6. Какое расширение имеют файлы программы Excel?

d) .xlsx

7. Минимальной составляющей таблицы в программе Excel является

c) ячейка

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота