kateadel01
13.05.2022 23:09

Требовалось составить программу для вычисления Y по формуле: 2Х+1, при всех значениях Х более 10, или по формуле: АХ-В, для всех остальных значений Х. Программист написал четыре варианта программы, но каждый раз ничего не получилось исправьте все ошибки (они могут быть как синтаксическими (т. е. не позволяют запустить программу), так и логическими (программа работает, но неправильно)). Это можно сделать как с среды программирования PascalABC, так и самостоятельно. Файл должен содержать Ваши исправления программы в следующем виде:
Неправильная строка исправить на: Правильная строка
Количество таких строк должно соответствовать количеству найденных ошибок. Изменять структуру программы, удалять или добавлять строки нельзя!

3 вариант
program vetvlenie3;
var a, b, x,y: real;
begin
readln (Y);
if x>0 then
y:=2x+1
else
y:=ax-b;
writeln (Y);
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MasterHaris
24.09.2022 12:21
Для удобства вычислений считаем, что ширина диапазона дискретизации составляет 100 В (т.е. напряжение может быть равно 0, 1, 2, .. 99 В).
При этом получаются 5 интервалов
  0 - 19 В
20 - 39 В
40 - 59 В
60 - 79 В
80 - 99 В
Значение 54 В попадает в третий интервал и напряжение после дискретизации считается равным 40В (нижняя граница диапазона).

Если очень важно, чтобы и 100В попадало в диапазон дискретизации, то его ширина будут равна 101 В, что потребует ввести поправку 0.2В в границы интервалов. ответ на задачу при этом изменится и будет нецелым.

ответ: 40 В
0,0(0 оценок)
Ответ:
Fox332
12.09.2021 12:08
Не указано, какая используется СУБД, ниже запросы подойдут для Postgresql:
1. select article.id from article  where article.text like '%beta%' or '%4%'
2. select article.id  from article where comments.text is NULL and article_comment_association.article_id=article.id and article_comment_association.сomment_id=comments.id
3. select users.name from users where users.id=article.user_id and article_comment_association.article_id=article.id and article_comment_association.сomment_id=comments.id
4. SELECT article.id, COUNT(comments.id) AS "CNT" from  article, comments
where article_comment_association.article_id=article.id and article_comment_association.сomment_id=comments.id 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота