Landess
28.07.2020 14:16

1. Какие значения может принимать целая переменная Y,если в программе записано:Y:=10+random(5)?
2. Используя функцию random(x),получите числа в диапазонах:от 1 до 10,от -10 до +10,от 50 до 100.
3. Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений.
4.Заполните случайными числами в диапазоне от 1 до 5 два массива:A [1:20] и B [1:20]. Найдите и выведите на экран только те элементы этих массивов,значение которых совпадают. Например,если A [2]=B [2]=4,то на экран надо вывести:
Номер:2 значение:4
5.Придумайте свои получения этих чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
instajoha2p09254
13.10.2020 13:13

1) От 10 до 14

2) random(1, 10); random(-10,10); random(50,100);

3)

var a:array[1..100] of integer;

   i, p, o:integer;

begin

 p := 0;

 o := 0;

 for i := 1 to 100 do

   a[i] := random(-20, 20);

 writeln(a);

 for i := 1 to 100 do begin

   if a[i] >= 0 then p := p + 1

   else o := o + 1;

 end;

 writeln('Положительных: ' + p);

 writeln('Отрицательных: ' + o);

end.

4)

var a:array[1..20] of integer;

   b:array[1..20] of integer;

   i:integer;

begin

 randomize;

 for i := 1 to 20 do

   begin

   a[i] := random(1, 5);

   b[i] := random(1, 5);

   end;

 for i := 1 to 20 do begin

   if a[i] = b[i] then begin

   writeln('Номер: ' + i);

   writeln('Значение: ' + a[i]);

   end;

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота