yakubovmalik
06.03.2022 17:43

Паскаль. Написать программу так чтобы в исходном массиве поменялись местами третий и пятый элементы массива.Написать ответ

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Andylov
27.11.2022 03:06
//Задание №1
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const m = 31;
var a:array[1..m] of integer;
i,s,n:integer;

begin
  for i:=1 to m do begin
    a[i]:=random(-20,20);
    if a[i]>0 then begin
      s:=s+a[i];n:=n+1;
    end;
  end;
  println('Температуры за месяц :'); a.println;
 writeln('Средняя в оттепель :',s/n:0:3);
end.

Тестовое решение:
Температуры за месяц :
16 7 19 -7 -18 6 12 -18 -5 -10 8 -4 10 4 10 5 -3 14 -7 -8 2 7 4 -7 18 4 -12 -5 -9 7 -5
Средняя в оттепель :9.000

//Задание №2
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const m = 10;
var a:array[1..m] of integer;
i,s,n:integer;

begin
  for i:=1 to m do begin
    a[i]:=random(-20,20);
    if i mod 2<>0 then s:=s+a[i];
  end;
  writeln('Исходный массив :'); a.println;
  for i:=1 to m do
    if i mod 2=0 then a[i]:=s;
  writeln('Сумма на нечетных местах  = ',s);
  writeln('Изиененный массив :'); a.println;
end.

Тестовое решение:
Исходный массив :
-6 15 5 -11 18 4 17 -9 -15 -16
Сумма на нечетных местах = 19
Изиененный массив :
-6 19 5 19 18 19 17 19 -15 19
0,0(0 оценок)
Ответ:
artemts242
08.03.2023 21:18
Из 1 и 4 следует, что Рыбаков и Перлов - не повара
Из 1 и 5 следует, что они не могут быть одновременно врачом и учителем.
Из 1 и 6 следует, что они не могут быть одновременно врачом и водителем.
Из двух предыдущих выводов следует, что Рыбаков и Перлов - учитель и водитель (кто есть кто - не важно), а Шмаков и Немцов - врач и повар.
Допустим, Шмаков врач. Тогда согласно 7 он старше учителя и водителя, т.е. Рыбакова и Перлова, что противоречит 2. Значит, Шмаков не врач, а повар. В таком случае Немцов - врач.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота