shefer84
24.04.2020 17:35

информатика, 7 класс
Написать программу вычисления двух выражений в Python(не обязательно в самой программе, можно на листе бумаги)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
danilvetrov47p083sl
16.05.2021 22:38

2000 Байтов.

Объяснение:

В алфавите 16 букв. Зная это информацию, мы можем воспользоватся формулой Хартли - N = 2^i, где N - мощность алфавита, а i - вес одного символа. 16 = 2^4. В задаче говорится, что все слова этого языка состоят из 5 букв. Выполнив обычные умножение, мы можем узнать вес одного слова в битах. 5 * 4 = 20 бит - вес одного слова. Далее просто вес одного слова умножим на их количество. 20 * 8000 = 160000. Нас просят  выразить информацию в Байтах, поэтому получившееся число разделим на 8, т.к. в одном Байте восемь бит информации. 160000 : 8 = 20000 Байтов - вес всех слов, составленных из букв алфавита.

0,0(0 оценок)
Ответ:
tiger071
23.03.2023 06:37
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  var m:=ReadInteger('число строк ');
  var n:=ReadInteger('число столбцов ');
  var a:array[,] of real; SetLength(a,m,n);
  Randomize;
  var p:=1.0;
  for var i:=0 to m-1 do begin
    for var j:=0 to n-1 do begin
      a[i,j]:=89*Random+10;
      Write(a[i,j]:0:5,' ');
      if j mod 2=0 then p*=a[i,j]
      end;
    Writeln
    end;
  Writeln(p)
end.

Тестовое решение:
число строк  4
число столбцов  3
83.48215 49.40392 38.47974
79.95518 85.86098 19.45080
34.86908 65.25898 51.15671
96.59641 24.22868 42.34227
36449203938146.9
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота