Yanaaa13
21.09.2021 19:44

написать программу, которая запрашивает у пользователя номер дома и номер квартиры и выводит это на экран.
2. написать программу, которая вычисляет периметр треугольника. Компьютер спрашивает у пользователя "введите длину стороны", пользователь набирает на клавиатуре, компьютер считывает. Находит периметр и выводит результат на экран
3.Написать программу, которая подсчитывает, сколько вы потратите в магазине денег на покупку: несколько тетрадей, несколько ручек, несколько карандашей. Количество(целое число) и цену (вещественное число) вводите с клавиатуры. Результат на экран
Для ввода разных типов-указываете эти типы в разделе var

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Алуопо
11.11.2022 07:46
1)Необходимы: данные задачи, условия, порядок действий.
2)Формы записи алгоритмов: графический (в виде блок-схемы), на естественном языке, на алгоритмическом языке, на языке программирования.
3)1. набрать в 9л-ое ведро полное и вылить из него в 5л-ое. освободить 5л-ое ведро.в 9л-ом останется 4 л.
2. переливает эти 4 л в 5л-ое ведро.
3. наполняет 9л-ое ведро и выливает в 5л-ое ещё 1 л. в 9л-ом остается 8 л. освобождает 5л-ое ведро.
4. переливает из9л-ого ведра 5 л. и в 9л-ом ведре остается ровно 3 л.
4)Геометрические фигуры в блок-схеме: овал - начало и конец алгоритма, прямоугольник - команды, параллелограмм - ввод и вывод данных, ромб - условие, шестиугольник - счетчик цикла.
5)Порядок выполнения отдельных действий в блок схеме задается в виде стрелок, соединяющих блоки.
0,0(0 оценок)
Ответ:
Ааллалалал44
21.09.2020 14:21
Var 
a: array[1..100] of integer; 
n, i: byte; 
sum, p: integer;
begin 
writeln('1. Случайным образом'); 
Randomize; 
write('Введите размер массива: '); 
readln(n); 
sum:=0; p:=1; 
for i:=1 to n do   
begin     
a[i]:=Random(101)-50;     
write(a[i]:4);     
sum:=sum+a[i];     
p:=p*a[i];   
end; 
writeln; 
writeln('Сумма = ', sum:5); 
writeln('Произведение = ', p:5); 
sum:=0; p:=1; 
writeln(''); 
writeln('2. С клавиатуры'); 
for i:=1 to n do   
begin   
write('Элемент ', i, ' = ');   
readln(a[i]);   
sum:=sum+a[i];   
p:=p*a[i];   
end; 
writeln('Сумма = ', sum:5); 
writeln('Произведение = ', p:5);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота