AlyonaAtlanta
12.07.2022 04:55

Составить программу и пояснение к задаче.
1. Даны два числа. Верно ли, что первое число, больше второго.
​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
VitaLevchenko2004
16.11.2020 22:03
Const
    handsfree = false;

var
    a: array[1..100] of real;
    i, n: integer;
    sum, product, harmonic: real;

begin
    {ввод массива}
    if handsfree then
        n := random(20) + 5
    else begin
        write('n = ');
        readln(n);
    end;
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100) - 50;
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
    
    
    {подсчет суммы и произведения и агригатов}
    sum := 0;
    for i := 1 to n do
        if abs(a[i]) <= 5 then
            sum := sum + a[i];
    writeln('sum = ', sum);
end.
0,0(0 оценок)
Ответ:
Zelikovakasimov
31.01.2022 03:27
2)
const
    handsfree = true;

var
    a: array[1..100] of real;
    i, n, mini: integer;

begin
    {ввод массива}
    if handsfree then
        n := random(27+27) -27
    else begin
        write('n = ');
        readln(n);
    end;
   
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100) - 50;
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
   
    {минимум и максимум}
    mini := 1;
    for i := 1 to n do
        if a[mini] > a[i] then mini := i;
    writeln('min = ', a[mini]);
    writeln('mini = ', mini);
end.

1)const
    handsfree = false;

var
    a: array[1..100] of real;
    i, n: integer;
    sum, product, harmonic: real;

begin
    {ввод массива}
    if handsfree then
        n := random(20) + 5
    else begin
        write('n = ');
        readln(n);
    end;
   
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100) - 50;
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
   
   
    {подсчет суммы и произведения и агригатов}
    sum := 0;
    for i := 1 to n do
        if abs(a[i]) <= 5 then
            sum := sum + a[i];
    writeln('sum = ', sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота